summaryrefslogtreecommitdiff
path: root/gnu/packages/audio.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-25 18:28:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-25 18:29:45 +0100
commitd1f9519c0047609cb02b5a0db13da9824c754c7e (patch)
tree6dc355264dcb84b07abd88f2ed1558aeb2971217 /gnu/packages/audio.scm
parentcb141aaf677ecd1fc846999cf3d091c021d6655e (diff)
gnu: jack-1: Update comment to recommend use of jack-2.
* gnu/packages/audio.scm (jack-1, jack-2): Update comments.
Diffstat (limited to 'gnu/packages/audio.scm')
-rw-r--r--gnu/packages/audio.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 8505e8fb0d..c39e43c8a1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
@@ -2366,6 +2366,8 @@ especially for creating reverb effects. It supports impulse responses with 1,
2 or 4 channels, in any soundfile format supported by libsndfile.")
(license license:gpl2+)))
+;; Packages depending on JACK should always prefer jack-2.
+;; JACK1 is provided for legacy applications
(define-public jack-1
(package
(name "jack")
@@ -2411,9 +2413,8 @@ synchronous execution of all clients, and low latency operation.")
;; licensed under the LGPL in order to allow for proprietary usage.
(license (list license:gpl2+ license:lgpl2.1+))))
-;; Packages depending on JACK should always prefer jack-1. Both jack-1 and
-;; jack-2 implement the same API. JACK2 is provided primarily as a client
-;; program for users who might benefit from the D-BUS features.
+;; Packages depending on JACK should always prefer jack-2. Both jack-1 and
+;; jack-2 implement the same API.
(define-public jack-2
(package
(inherit jack-1)