summaryrefslogtreecommitdiff
path: root/gnu/packages/aux-files/emacs
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-04 20:54:49 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-04 20:54:49 +0100
commit19fc252ab7e86ad1443a8d16f68467c61bf23179 (patch)
treec892c663056aa9e56c3724f8821951eb2a60315e /gnu/packages/aux-files/emacs
parent84e125eb27bc97dc00c260bb03238447134f6d5c (diff)
aux-files: comp-integrity: Adjust for emacs-pgtk.
* gnu/packages/aux-files/emacs/comp-integrity.el (x-dnd-init-frame): Require x-dnd. (x-handle-no-bitmap-icon): Only test this if it's bound.
Diffstat (limited to 'gnu/packages/aux-files/emacs')
-rw-r--r--gnu/packages/aux-files/emacs/comp-integrity.el5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/aux-files/emacs/comp-integrity.el b/gnu/packages/aux-files/emacs/comp-integrity.el
index 9692d9bf97..191e2ddb98 100644
--- a/gnu/packages/aux-files/emacs/comp-integrity.el
+++ b/gnu/packages/aux-files/emacs/comp-integrity.el
@@ -125,5 +125,6 @@
(expect-native emacs-version)
(expect-native define-widget)
(expect-native window-right)
-(expect-native x-dnd-init-frame)
-(expect-native x-handle-no-bitmap-icon)
+(expect-native x-dnd-init-frame x-dnd)
+(and (boundp 'x-handle-no-bitmap-icon)
+ (expect-native x-handle-no-bitmap-icon))