summaryrefslogtreecommitdiff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-06 13:48:57 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-06 13:53:28 +0100
commit3f11f01fa88f2fbdf46e05117b82909b1b224d28 (patch)
tree0ec66854f635fd440fc5321cee16b325ee4ff4fe /gnu/packages/base.scm
parentca63770ab1de0ae8723a560a87cc73c98b0d22ff (diff)
gnu: patch: Add 2.7.4 and make it a replacement for the default one.
* gnu/packages/base.scm (patch-2.7.4, patch-CVE-2015-1196): New variables. (patch): Add 'replacement' field.
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 1f479ccbbe..be33cb2caf 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
@@ -167,8 +167,27 @@ files depending on the contents of the diff file. It accepts several
different diff formats. It may also be used to revert previously applied
differences.")
(license gpl3+)
+ (replacement patch-CVE-2015-1196)
(home-page "http://savannah.gnu.org/projects/patch/")))
+(define-public patch-2.7.4
+ (package
+ (inherit patch)
+ (version "2.7.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/patch/patch-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "02gikxjvcxysr4l65c8vivgz62xmalp0av5ypzff8vqhrq3vpb0f"))))
+ (replacement #f)))
+
+(define patch-CVE-2015-1196
+ (package (inherit patch-2.7.4)
+ ;; Keep the old version number so it can be used as a 'replacement'.
+ (version (package-version patch))))
+
(define-public diffutils
(package
(name "diffutils")