summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-02 03:26:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-07 10:29:59 +0100
commit372843576d0efd50d2d4d97dd536b7293e9dc180 (patch)
tree64fb7de4fa9f02639a59899aecc6e5cca48c2b94 /gnu/packages/bioconductor.scm
parentc738ab4805819799c0e8f9db7b016802fa48076b (diff)
gnu: Add r-tilingarray.
* gnu/packages/bioconductor.scm (r-tilingarray): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b5a120c267..de20271329 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14989,6 +14989,47 @@ be applied to the analysis of other NGS data obtained from experimental
procedures that induce nucleotide substitutions (e.g. BisSeq).")
(license license:gpl2)))
+(define-public r-tilingarray
+ (package
+ (name "r-tilingarray")
+ (version "1.76.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "tilingArray" version))
+ (sha256
+ (base32
+ "19bkgblpkcp3w3sdyn82c37gkz1sv3r4d546zpbnh36q2pi3l4zd"))))
+ (properties `((upstream-name . "tilingArray")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-affy
+ r-biobase
+ r-genefilter
+ r-pixmap
+ r-rcolorbrewer
+ r-strucchange
+ r-vsn))
+ (home-page "https://bioconductor.org/packages/tilingArray")
+ (synopsis "Transcript mapping with high-density oligonucleotide tiling arrays")
+ (description
+ "The package provides functionality that can be useful for the analysis
+of the high-density tiling microarray data (such as from Affymetrix genechips)
+or for measuring the transcript abundance and the architecture. The main
+functionalities of the package are:
+
+@enumerate
+@item the class segmentation for representing partitionings of a linear series
+ of data;
+@item the function segment for fitting piecewise constant models using a
+ dynamic programming algorithm that is both fast and exact;
+@item the function @code{confint} for calculating confidence intervals using
+ the @code{strucchange} package;
+@item the function @code{plotAlongChrom} for generating pretty plots;
+@item the function @code{normalizeByReference} for probe-sequence dependent
+ response adjustment from a (set of) reference hybridizations.
+@end enumerate")
+ (license license:artistic2.0)))
+
(define-public r-timeseriesexperiment
(package
(name "r-timeseriesexperiment")