summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:16:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:16:41 +0200
commit48e300bd3f83ebab4d689501a7dec88611f2de4b (patch)
treeae0387fc8a471877221eafc0c1e3a98b6e8807ab /gnu/packages/bioconductor.scm
parent2c8e3595e3d3a63dc4c0832025242d35c94b0100 (diff)
gnu: Add r-biodb.
* gnu/packages/bioconductor.scm (r-biodb): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 05b6aa118d..e1adb87738 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -14074,6 +14074,50 @@ the BiocDockerManager package to install and manage Docker images provided by
the Bioconductor project.")
(license license:artistic2.0)))
+(define-public r-biodb
+ (package
+ (name "r-biodb")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "biodb" version))
+ (sha256
+ (base32
+ "1apnbr5p619nsrhd2drm6arj69sw0wijv8ap7dfrndqkffrpbfmx"))))
+ (properties `((upstream-name . "biodb")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-chk" ,r-chk)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-lgr" ,r-lgr)
+ ("r-lifecycle" ,r-lifecycle)
+ ("r-openssl" ,r-openssl)
+ ("r-plyr" ,r-plyr)
+ ("r-progress" ,r-progress)
+ ("r-r6" ,r-r6)
+ ("r-rappdirs" ,r-rappdirs)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-stringr" ,r-stringr)
+ ("r-testthat" ,r-testthat)
+ ("r-withr" ,r-withr)
+ ("r-xml" ,r-xml)
+ ("r-yaml" ,r-yaml)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/biodb")
+ (synopsis "Library for connecting to chemical and biological databases")
+ (description
+ "The biodb package provides access to standard remote chemical and
+biological databases (ChEBI, KEGG, HMDB, ...), as well as to in-house local
+database files (CSV, SQLite), with easy retrieval of entries, access to web
+services, search of compounds by mass and/or name, and mass spectra matching
+for LCMS and MSMS. Its architecture as a development framework facilitates
+the development of new database connectors for local projects or inside
+separate published packages.")
+ (license license:agpl3+)))
+
(define-public r-tximeta
(package
(name "r-tximeta")