summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-23 19:06:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 17:40:28 +0100
commit610cd6a170474550dffd8a58eb3651ef10ca7f6e (patch)
tree607854b0a60ef70d51ab00ecc2343b27a65a4471 /gnu/packages/bioconductor.scm
parent81f481d6cdbbd035c1642d9d257af6805f4d22dc (diff)
gnu: r-ggbio: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-ggbio): Move from here... * gnu/packages/bioconductor.scm (r-ggbio): ...to here.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a3dd93e763..55df9bf7d1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9308,6 +9308,71 @@ metadata and outputs of the ChromImpute procedure applied to ENCODE cell lines
by Ernst and Kellis.")
(license license:artistic2.0)))
+(define-public r-ggbio
+ (package
+ (name "r-ggbio")
+ (version "1.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ggbio" version))
+ (sha256
+ (base32
+ "0vabil4jzrlv01aibqjhdkvrv2bf2kkpsidrkjj06isqr5fz54lw"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; See https://github.com/tengfei/ggbio/issues/117
+ ;; This fix will be included in the next release.
+ (add-after 'unpack 'fix-typo
+ (lambda _
+ (substitute* "R/GGbio-class.R"
+ (("fechable") "fetchable"))
+ #t)))))
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-annotationfilter" ,r-annotationfilter)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-biovizbase" ,r-biovizbase)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-ensembldb" ,r-ensembldb)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggally" ,r-ggally)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gtable" ,r-gtable)
+ ("r-hmisc" ,r-hmisc)
+ ("r-iranges" ,r-iranges)
+ ("r-organismdbi" ,r-organismdbi)
+ ("r-reshape2" ,r-reshape2)
+ ("r-rlang" ,r-rlang)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-scales" ,r-scales)
+ ("r-summarizedexperiment" ,r-summarizedexperiment)
+ ("r-variantannotation" ,r-variantannotation)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "http://www.tengfei.name/ggbio/")
+ (synopsis "Visualization tools for genomic data")
+ (description
+ "The ggbio package extends and specializes the grammar of graphics for
+biological data. The graphics are designed to answer common scientific
+questions, in particular those often asked of high throughput genomics data.
+All core Bioconductor data structures are supported, where appropriate. The
+package supports detailed views of particular genomic regions, as well as
+genome-wide overviews. Supported overviews include ideograms and grand linear
+views. High-level plots include sequence fragment length, edge-linked
+interval to data view, mismatch pileup, and several splicing summaries.")
+ (license license:artistic2.0)))
+
(define-public r-gqtlbase
(package
(name "r-gqtlbase")