summaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-26 13:09:34 +0200
committerRoel Janssen <roel@gnu.org>2021-05-26 13:09:34 +0200
commit834f649590db5939e3cd5a18097c7803bd625f82 (patch)
tree0bef467b2f5915e901070f22ceb70cfac9e2440d /gnu/packages/bioconductor.scm
parent3d704fafbaf5f4796f1c688c412f4b1cb77e916f (diff)
gnu: Add r-geneoverlap.
* gnu/packages/bioconductor.scm (r-geneoverlap): New variable.
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 3359ce16cb..22568353af 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1127,6 +1127,26 @@ annotation, distance to TSS, and overlap of peaks or genes.")
genomes and gene ID formats, largely based on the UCSC table browser.")
(license license:lgpl2.0+)))
+(define-public r-geneoverlap
+ (package
+ (name "r-geneoverlap")
+ (version "1.26.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GeneOverlap" version))
+ (sha256
+ (base32
+ "0bvh00n4fx0h1m83bypib3jvln1ihcv77ywrrn9xm20y73gymhkh"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-gplots" ,r-gplots)))
+ (home-page "https://www.bioconductor.org/packages/GeneOverlap/")
+ (synopsis "Test and visualize gene overlaps")
+ (description "This package can be used to test two sets of gene lists
+and visualize the results.")
+ (license license:gpl3)))
+
(define-public r-pasilla
(package
(name "r-pasilla")