summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-09-22 08:19:09 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-09-22 09:16:47 +1000
commit05fb1e0017030f1c0cbc7e9a1adeccca57ef1d9d (patch)
tree8d6f02eee6074d0243589ea5a6939a0bfcac06f4 /gnu/packages/bioinformatics.scm
parent78b7b9dbe9098c9c47c7acba363223bb6c5bb1c8 (diff)
gnu: hmmer: Update to 3.2.1.
* gnu/packages/bioinformatics.scm (hmmer): Update to 3.2.1. [origin]: Remove patch. [license]: Change to BSD-3. [supported-systems]: New field. * gnu/packages/patches/hmmer-remove-cpu-specificity.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9599e3096f..b619866ba3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2936,18 +2936,15 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
(define-public hmmer
(package
(name "hmmer")
- (version "3.1b2")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (string-append
- "http://eddylab.org/software/hmmer"
- (version-major version) "/"
- version "/hmmer-" version ".tar.gz"))
+ "http://eddylab.org/software/hmmer/hmmer-" version ".tar.gz"))
(sha256
(base32
- "0djmgc0pfli0jilfx8hql1axhwhqxqb8rxg2r5rg07aw73sfs5nx"))
- (patches (search-patches "hmmer-remove-cpu-specificity.patch"))))
+ "171bivy6xhgjsz5nv53n81pc3frnwz29ylblawk2bv46szwjjqd5"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(home-page "http://hmmer.org/")
@@ -2957,12 +2954,10 @@ indexing scheme is called a @dfn{Hierarchical Graph FM index} (HGFM).")
sequences, and for making protein sequence alignments. It implements methods
using probabilistic models called profile hidden Markov models (profile
HMMs).")
- (license (list license:gpl3+
- ;; The bundled library 'easel' is distributed
- ;; under The Janelia Farm Software License.
- (license:non-copyleft
- "file://easel/LICENSE"
- "See easel/LICENSE in the distribution.")))))
+ ;; hmmer uses non-portable SSE intrinsics so building fails on other
+ ;; platforms.
+ (supported-systems '("x86_64-linux" "i686-linux"))
+ (license license:bsd-3)))
(define-public htseq
(package