summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-06-19 14:53:24 +0000
committerAndreas Enge <andreas@enge.fr>2024-06-30 10:48:50 +0200
commit1731b45c51e1de1839a7b862ab50ba1c876e745f (patch)
treef061503989d60ef40fb6e7101dfc146d4e8db579 /gnu/packages/bioinformatics.scm
parent0e5ecc6868835151add861230314edc5c9897e97 (diff)
gnu: Add r-cmdstanr.
* gnu/packages/bioinformatics.scm (r-cmdstanr): New variable. Change-Id: Ic9e83486f7ab7f0e7075343af630c4dcecf597b5 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b6e7986a1f..a41c60738a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2022, 2023 Navid Afkhami <navid.afkhami@mdc-berlin.de>
+;;; Copyright © 2022, 2023, 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2024 Alexis Simon <alexis.simon@runbox.com>
;;;
@@ -11534,6 +11534,41 @@ tasks.")
Pore-C concatemers.")
(license license:gpl3))))
+(define-public r-cmdstanr
+ (let ((commit "a45d4f7d686aa6b57ce25f342a71eea79507f01c")
+ (revision "1"))
+ (package
+ (name "r-cmdstanr")
+ (version (git-version "0.8.1.9000" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stan-dev/cmdstanr")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01vyh3sy704rs7yvaka2hp6vld0mdl7hbrs20dpbwidgm4ksrvsi"))))
+ (properties `((upstream-name . "cmdstanr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate
+ r-data-table
+ r-jsonlite
+ r-posterior
+ r-processx
+ r-r6
+ r-rlang
+ r-withr))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/stan-dev/cmdstanr")
+ (synopsis "R interface to 'CmdStan'")
+ (description
+ "This package provides a lightweight interface to Stan
+<https://mc-stan.org>. The @code{CmdStanR} interface is an alternative
+to RStan that calls the command line interface for compilation and
+running algorithms instead of interfacing with C++ via Rcpp'.")
+ (license license:bsd-3))))
+
(define-public r-dnamcrosshyb
;; There aren't any releases.
(let ((commit "fe8acb33667e81f00dcb84e0fa75c87ab2db5d8f")