summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-14 16:36:30 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-16 10:28:37 +0200
commit2127cedb23ab051d9f03bdab7b7ae5d5c472baff (patch)
tree49d97d20d56dc13760fb828d5192ae9bc54b0879 /gnu/packages/bioinformatics.scm
parentf571e1c34600dc4621506e8745e36442f9896970 (diff)
gnu: Add FASTX Toolkit.
* gnu/packages/bioinformatics.scm (fastx-toolkit): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1ad5f600fb..b1258220b4 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages statistics)
#:use-module (gnu packages swig)
#:use-module (gnu packages tbb)
+ #:use-module (gnu packages textutils)
#:use-module (gnu packages vim)
#:use-module (gnu packages xml)
#:use-module (gnu packages zip))
@@ -471,6 +472,38 @@ file formats including SAM/BAM, Wiggle/BigWig, BED, GFF/GTF, VCF.")
other types of unwanted sequence from high-throughput sequencing reads.")
(license license:expat)))
+(define-public fastx-toolkit
+ (package
+ (name "fastx-toolkit")
+ (version "0.0.14")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://github.com/agordon/fastx_toolkit/releases/download/"
+ version "/fastx_toolkit-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "01jqzw386873sr0pjp1wr4rn8fsga2vxs1qfmicvx1pjr72007wy"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libgtextutils" ,libgtextutils)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://hannonlab.cshl.edu/fastx_toolkit/")
+ (synopsis "Tools for FASTA/FASTQ file preprocessing")
+ (description
+ "The FASTX-Toolkit is a collection of command line tools for Short-Reads
+FASTA/FASTQ files preprocessing.
+
+Next-Generation sequencing machines usually produce FASTA or FASTQ files,
+containing multiple short-reads sequences. The main processing of such
+FASTA/FASTQ files is mapping the sequences to reference genomes. However, it
+is sometimes more productive to preprocess the files before mapping the
+sequences to the genome---manipulating the sequences to produce better mapping
+results. The FASTX-Toolkit tools perform some of these preprocessing tasks.")
+ (license license:agpl3+)))
+
(define-public flexbar
(package
(name "flexbar")