summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 23:34:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:35 +0100
commit447876fa0ddc1ed74e95762a1e089da457d7c85b (patch)
tree97b454383c98c59e7fbc2922c1fdbcb141ed7947 /gnu/packages/bioinformatics.scm
parent6a2f1863e7707fc958efa417285161c7eced4904 (diff)
gnu: python-scanpy: Update to 1.9.6.
* gnu/packages/bioinformatics.scm (python-scanpy): Update to 1.9.6. [arguments]: Update test flags. [native-inputs]: Add python-hatchling, python-hatch-vcs, and python-pytest-nunit. Change-Id: I6d4dcd267a076c5697ed103650841f520dc9917f
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 19 insertions, 13 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f75254ed9f..1f707a31c1 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -16449,7 +16449,7 @@ implementation differs in these ways:
(define-public python-scanpy
(package
(name "python-scanpy")
- (version "1.9.1")
+ (version "1.9.6")
(source
(origin
(method git-fetch)
@@ -16459,21 +16459,28 @@ implementation differs in these ways:
(file-name (git-file-name name version))
(sha256
(base32
- "0k524xnx3dvpz5yx65p316wghvi01zs17is8w2m3w2qywiswk0sl"))))
+ "12rz0a9151fkry6ws1a8p5wnc4n5qbjl6xlynj7kxy223iz8isds"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
'(list "-k"
;; Plot tests that fail.
- (string-append "not test_dotplot_matrixplot_stacked_violin"
- " and not test_violin_without_raw"
- " and not test_correlation"
- " and not test_scatterplots"
- " and not test_scatter_embedding_add_outline_vmin_vmax_norm"
- " and not test_paga"
+ (string-append "not test_clustermap"
+ " and not test_dotplot_matrixplot_stacked_violin"
" and not test_paga_compare"
- " and not test_clustermap"
+ " and not test_paga_path"
+ " and not test_paga_pie"
+ " and not test_paga_plots"
+ " and not test_violin"
+ " and not test_scatter_no_basis_per_obs"
+
+ ;; Type mismatch
+ " and not test_obs_df"
+ " and not test_var_df"
+
+ ;; Minor accuracy problem
+ " and not test_consistency[morans_i-allclose]"
;; These try to connect to the network
" and not test_scrublet_plots"
@@ -16505,10 +16512,6 @@ implementation differs in these ways:
;; These two fail with "ValueError: I/O operation on closed file."
(delete-file "scanpy/tests/test_neighbors_key_added.py")
- ;; TODO: these fail with TypingError and "Use of unsupported
- ;; NumPy function 'numpy.split'".
- (delete-file "scanpy/tests/test_metrics.py")
-
;; The following tests requires 'scanorama', which isn't
;; packaged yet.
(delete-file "scanpy/tests/external/test_scanorama_integrate.py")
@@ -16549,8 +16552,11 @@ implementation differs in these ways:
`(;; This package needs anndata.tests, which is not installed.
("python-anndata:source" ,(package-source python-anndata))
("python-flit" ,python-flit)
+ ("python-hatchling" ,python-hatchling)
+ ("python-hatch-vcs" ,python-hatch-vcs)
("python-leidenalg" ,python-leidenalg)
("python-pytest" ,python-pytest)
+ ("python-pytest-nunit" ,python-pytest-nunit)
("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "https://github.com/theislab/scanpy")
(synopsis "Single-Cell Analysis in Python")