summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-01-11 14:47:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-12 21:37:56 +0100
commit483bc044eb868f533c7e6923bb93398fcf04f9ba (patch)
tree59da813b8db6b0111291491bcb9481f0898bc4f7 /gnu/packages/bioinformatics.scm
parent98ef4ab23edb88e8dd09948f52f34fecbf9500f3 (diff)
gnu: Add cellsnp-lite.
* gnu/packages/bioinformatics.scm (cellsnp-lite): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6e909773a7..aff2f6dd9f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
-;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021, 2022, 2023 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Navid Afkhami <navid.afkhami@mdc-berlin.de>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
@@ -512,6 +512,49 @@ BED, GFF/GTF, VCF.")
(inputs
(list samtools zlib))))
+(define-public cellsnp-lite
+ ;; Last release is from November 2021 and does not contain fixes.
+ (let ((commit "0885d746b0b1ea65c8ef92f8943ca7669ca9734a")
+ (revision "0"))
+ (package
+ (name "cellsnp-lite")
+ (version (git-version "1.2.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/single-cell-genetics/cellsnp-lite")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qrvqgbvw6mbhpyqvqbmvv8dmyc67bsk1041cn7ib6zmd47qm444"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:configure-flags
+ #~(list (string-append "--with-htslib="
+ #$(this-package-input "htslib")))))
+ (inputs
+ (list curl
+ htslib
+ openssl
+ zlib))
+ (native-inputs
+ (list autoconf))
+ (home-page "https://cellsnp-lite.readthedocs.io")
+ (synopsis "Pileup expresses alleles in single-cell or bulk RNA-seq data")
+ (description
+ "This package is designed to pileup the expressed alleles in
+single-cell or bulk RNA-seq data, which can be directly used for donor
+deconvolution in multiplexed single-cell RNA-seq data, particularly with other
+packages, which assigns cells to donors and detects doublets as vireo, even
+without genotyping reference.
+
+This package is the C version of the deprecated cellSNP implemented in Python.
+Compared to cellSNP, this package is more efficient with higher speed and less
+memory usage.")
+ (license license:asl2.0))))
+
(define-public pbcopper
(package
(name "pbcopper")