summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-02-09 09:12:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-09 11:05:29 +0100
commit4d35a5e2b6486e24bb74665ab6a65ca0cfd0b475 (patch)
tree702e5a4e50a6d40f0b04682d582338c636d791f7 /gnu/packages/bioinformatics.scm
parent43ee3e1da226ff23849cc33f9d0903c593897c9a (diff)
gnu: Add python-scrublet.
* gnu/packages/bioinformatics.scm (python-scrublet): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 055c8ca47b..fdf52c5851 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3459,6 +3459,35 @@ and record oriented data modeling and the Semantic Web.")
resources for bioinformatics.")
(license license:bsd-3)))
+(define-public python-scrublet
+ (package
+ (name "python-scrublet")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "scrublet" version))
+ (sha256
+ (base32
+ "0fk5pwk12yz9wpvwkl6j2l2g28f3x35b9r9n5bw6f0i9f0qgd191"))))
+ (build-system pyproject-build-system)
+ (arguments '(#:tests? #false)) ;there are none
+ (propagated-inputs
+ (list python-annoy
+ python-cython
+ python-matplotlib
+ python-numba
+ python-numpy
+ python-pandas
+ python-scikit-image
+ python-scikit-learn
+ python-scipy
+ python-umap-learn))
+ (home-page "https://github.com/swolock/scrublet")
+ (synopsis "Tool to indentify and remove doublets in single-cell data")
+ (description "This package provides a tool for identifying and removing
+doublets in single-cell RNA-seq data.")
+ (license license:expat)))
+
(define-public cwltool
(package
(name "cwltool")