summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-30 12:25:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commit5def84031f4c7e45fc77ef2ed5c64190f937a41a (patch)
tree23143d16d1b95333e467bf62878cca5f3848fc03 /gnu/packages/bioinformatics.scm
parent8f8cee9ed9f5a5514f72efcd8d1af4947781801b (diff)
gnu: tadbit: Use G-expression.
* gnu/packages/bioinformatics.scm (tadbit)[arguments]: Use G-expression. Change-Id: I4fe4afc41eb3442f243b0e415ddcb363be36ce7f
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 746c78b596..8cae47a9da 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14113,29 +14113,28 @@ applications for tackling some common problems in a user-friendly way.")
"17nwlvjgqpa7x6jgh56m3di61ynaz34kl1jamyv7r2a5rhfcbkla"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-problems-with-setup.py
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/test/Makefile"
- (("^CFLAGS=") "CFLAGS= -fcommon"))
-
- ;; Don't attempt to install the bash completions to
- ;; the home directory.
- (rename-file "extras/.bash_completion"
- "extras/tadbit")
- (substitute* "setup.py"
- (("\\(path.expanduser\\('~'\\)")
- (string-append "(\""
- (assoc-ref outputs "out")
- "/etc/bash_completion.d\""))
- (("extras/\\.bash_completion")
- "extras/tadbit"))))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python3" "test/test_all.py")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-problems-with-setup.py
+ (lambda _
+ (substitute* "src/test/Makefile"
+ (("^CFLAGS=") "CFLAGS= -fcommon"))
+
+ ;; Don't attempt to install the bash completions to
+ ;; the home directory.
+ (rename-file "extras/.bash_completion"
+ "extras/tadbit")
+ (substitute* "setup.py"
+ (("\\(path.expanduser\\('~'\\)")
+ (string-append "(\"" #$output
+ "/etc/bash_completion.d\""))
+ (("extras/\\.bash_completion")
+ "extras/tadbit"))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "test/test_all.py")))))))
(native-inputs
(list `(,glib "bin") ;for gtester
glib