summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-06 10:52:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-06 10:52:24 +0100
commita582d863465990642d331bc05bf073f47fb80908 (patch)
tree48e4d44c85c64b74aabdf2d21cd211a9b0b84531 /gnu/packages/bioinformatics.scm
parent0890cb97473f1ec8d03cec2347f63deb546d2231 (diff)
gnu: Add r-ggsankey.
* gnu/packages/bioinformatics.scm (r-ggsankey): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 656eb7f13a..ef1e7ae988 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7995,6 +7995,36 @@ sequence.")
3D perspective axes, 3D perspective annotations, and wireframe plots.")
(license license:gpl3+))))
+(define-public r-ggsankey
+ (let ((commit "be08dd0f86eaee9f9ff9e7ff95d47930660a3c36")
+ (revision "1"))
+ (package
+ (name "r-ggsankey")
+ (version (git-version "0.0.99999" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/davidsjoberg/ggsankey")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0acpmydqqc91pq5p9wpkpmgqp3nhiljabd7d3i00kwhjxgm2bvba"))))
+ (properties `((upstream-name . "ggsankey")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-ggplot2
+ r-magrittr
+ r-purrr
+ r-stringr
+ r-tidyr))
+ (home-page "https://github.com/davidsjoberg/ggsankey")
+ (synopsis "Sankey, Alluvial and Sankey bump plots")
+ (description
+ "This package provides a package that makes it easy to implement
+sankey, alluvial and sankey bump plots in @code{ggplot2}.")
+ (license license:expat))))
+
(define-public r-gutils
(let ((commit "10e36c7b580aacb2d952140a3fdd82418aaddea6")
(revision "1"))