summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-09-05 16:00:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-10 16:50:26 +0200
commita9d496b353e71f22e5ace5bff9319fc74dfb6643 (patch)
treed2594d6f5d850a59bd2081a758de2dfe69381feb /gnu/packages/bioinformatics.scm
parenta6a7156aa970b08821a00599d7941740d8a22b70 (diff)
gnu: Add python-intervaltree.
* gnu/packages/bioinformatics.scm (python-intervaltree): New variable.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 6580cac531..dd8ed725d8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13504,3 +13504,31 @@ reference transcripts provided in a annotation file (also in GTF/GFF3 format).
(list
license:expat ;license for gffcompare
license:artistic2.0))))) ;license for gclib
+
+(define-public python-intervaltree
+ (package
+ (name "python-intervaltree")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "intervaltree" version))
+ (sha256
+ (base32
+ "02w191m9zxkcjqr1kv2slxvhymwhj3jnsyy3a28b837pi15q19dc"))))
+ (build-system python-build-system)
+ ;; FIXME: error when collecting tests
+ (arguments '(#:tests? #f))
+ (propagated-inputs
+ `(("python-sortedcontainers" ,python-sortedcontainers)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/chaimleib/intervaltree")
+ (synopsis "Editable interval tree data structure")
+ (description
+ "This package provides a mutable, self-balancing interval tree
+implementation for Python. Queries may be by point, by range overlap, or by
+range envelopment. This library was designed to allow tagging text and time
+intervals, where the intervals include the lower bound but not the upper
+bound.")
+ (license license:asl2.0)))