summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-31 15:46:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:46:30 +0200
commitb0ecd6cea90838018744bfad15662abf8f1b0025 (patch)
tree23c23f1ed75e0013856cd2826f8479024073bd9d /gnu/packages/bioinformatics.scm
parentc294c0d782bf36a88e24eb4efcd2fbbf8209ace2 (diff)
gnu: r-phantompeakqualtools: Let-bind commit, set revision to 1.
* gnu/packages/bioinformatics.scm (r-phantompeakqualtools): Bind the commit outside of the package value. [version]: Use git-version. [source]: Use git-file-name.
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm86
1 files changed, 44 insertions, 42 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 11dbad5a22..a7ff938647 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7977,51 +7977,53 @@ other functional sequencing data.")
(license license:gpl2)))
(define-public r-phantompeakqualtools
- (package
- (name "r-phantompeakqualtools")
- (version "1.2.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/kundajelab/phantompeakqualtools")
- (commit "8d2b2d18c686d894ef5908b37da7adf72a07ef42")))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "00anrvcwsp02d98qhj1xpj85644h2pp4kfzq6dgbmwmdr6jvy7p4"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; There are no tests.
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((script (string-append (assoc-ref outputs "out")
- "/share/scripts")))
- (install-file "run_spp.R" script)))))))
- (inputs
- `(("r" ,r-minimal)))
- (propagated-inputs
- `(("r-catools" ,r-catools)
- ("r-snow" ,r-snow)
- ("r-snowfall" ,r-snowfall)
- ("r-bitops" ,r-bitops)
- ("r-rsamtools" ,r-rsamtools)
- ("r-spp" ,r-spp)
- ("gawk" ,gawk)
- ("samtools" ,samtools)
- ("boost" ,boost)
- ("gzip" ,gzip)))
- (home-page "https://github.com/kundajelab/phantompeakqualtools")
- (synopsis "Informative enrichment for ChIP-seq data")
- (description "This package computes informative enrichment and quality
+ (let ((commit "8d2b2d18c686d894ef5908b37da7adf72a07ef42")
+ (revision "1"))
+ (package
+ (name "r-phantompeakqualtools")
+ (version (git-version "1.2.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kundajelab/phantompeakqualtools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00anrvcwsp02d98qhj1xpj85644h2pp4kfzq6dgbmwmdr6jvy7p4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; There are no tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((script (string-append (assoc-ref outputs "out")
+ "/share/scripts")))
+ (install-file "run_spp.R" script)))))))
+ (inputs
+ `(("r" ,r-minimal)))
+ (propagated-inputs
+ `(("r-catools" ,r-catools)
+ ("r-snow" ,r-snow)
+ ("r-snowfall" ,r-snowfall)
+ ("r-bitops" ,r-bitops)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-spp" ,r-spp)
+ ("gawk" ,gawk)
+ ("samtools" ,samtools)
+ ("boost" ,boost)
+ ("gzip" ,gzip)))
+ (home-page "https://github.com/kundajelab/phantompeakqualtools")
+ (synopsis "Informative enrichment for ChIP-seq data")
+ (description "This package computes informative enrichment and quality
measures for ChIP-seq/DNase-seq/FAIRE-seq/MNase-seq data. It can also be
used to obtain robust estimates of the predominant fragment length or
characteristic tag shift values in these assays.")
- (license license:bsd-3)))
+ (license license:bsd-3))))
(define-public r-r4rna
(package