summaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-22 15:26:30 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-22 15:26:30 +0100
commitf30830b2e67d973f2363903dbe5b27269da1901a (patch)
tree851a3a361cde2e083c418c54a1932bd57096c5a0 /gnu/packages/bioinformatics.scm
parent34f1838f04c7c359da8dbba86817499630ce7f01 (diff)
parent25ec3684e3529fae290d389ba11755c7e7c016ea (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e17c53675c..d4661cf515 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2298,6 +2298,22 @@ data and settings.")
("cairo" ,cairo)))
(native-inputs
`(("texlive" ,texlive)
+ ;; TODO: Replace texlive with minimal texlive-union.
+ ;; ("texlive" ,(texlive-union (list texlive-latex-doi
+ ;; texlive-latex-hyperref
+ ;; texlive-latex-oberdiek
+ ;; texlive-generic-ifxetex
+ ;; texlive-latex-url
+ ;; texlive-latex-pgf
+ ;; texlive-latex-examplep
+ ;; texlive-latex-natbib
+ ;; texlive-latex-verbatimbox
+ ;; texlive-latex-ms
+ ;; texlive-latex-xcolor
+ ;; texlive-fonts-amsfonts
+ ;; texlive-latex-amsfonts
+ ;; ;; ...
+ ;; )))
("imagemagick" ,imagemagick)))
(home-page "http://dorina.mdc-berlin.de/public/rajewsky/discrover/")
(synopsis "Discover discriminative nucleotide sequence motifs")
@@ -11390,7 +11406,10 @@ remove biased methylation positions for RRBS sequence files.")
(out (assoc-ref outputs "out"))
(bin (string-append out "/bin/"))
(target (string-append
- out "/lib/python2.7/site-packages/gess/")))
+ out "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages/gess/")))
(mkdir-p target)
(copy-recursively "." target)
;; Make GESS.py executable