summaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-21 05:46:47 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-21 17:24:29 +0200
commit4750b3a268ed511fd50e6b348a1a81b5f76b5a40 (patch)
treebe8d2cd016657798c8baac2e0632be9686fa4572 /gnu/packages/check.scm
parente2c7b7bb68594c2f4f3a13e98da1e32509a080a5 (diff)
gnu: python-pytest: Run the tests again.
"python setup.py test" is ineffective since 3.6.x. The circle is complete. * gnu/packages/check.scm (python-pytest)[arguments]: Override 'check' phase. [native-inputs]: Add PYTHON-PYTEST-BOOTSTRAP.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 572761f661..ddd532528f 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -642,7 +642,8 @@ standard library.")
(string-append "@pytest.mark.skip"
"(reason=\"Assumes that /usr exists.\")\n "
line)))
- #t)))))
+ #t))
+ (replace 'check (lambda _ (invoke "pytest" "-vv"))))))
(propagated-inputs
`(("python-atomicwrites" ,python-atomicwrites)
("python-attrs" ,python-attrs-bootstrap)
@@ -656,6 +657,7 @@ standard library.")
("python-hypothesis" ,python-hypothesis)
("python-nose" ,python-nose)
("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest-bootstrap)
("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "http://pytest.org")
(synopsis "Python testing library")