summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2020-02-03 11:46:25 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-02-17 23:21:05 +0100
commit22a9f128ad00586ce0d4ef332e80b14d43b89c54 (patch)
treeda2cf439b418fd511fc95b29f2959be3fbe3d409 /gnu/packages/commencement.scm
parent2ca7af43fe17d9acf082dce85d137a27a8ac4887 (diff)
gnu: commencement: Remove %bootstrap-guile+guild.
* gnu/packages/commencement.scm (%bootstrap-guile+guild): Remove variable.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm58
1 files changed, 0 insertions, 58 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 663c0054db..aa868c9e21 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -83,64 +83,6 @@
;;;
;;; Code:
-(define %bootstrap-guile+guild
- ;; This package combines %bootstrap-guile with guild, which is not included
- ;; in %bootstrap-guile. Guild is needed to build gash-boot and
- ;; gash-utils-boot because it is dependency of the Guile build system.
- (package
- (name "guile-bootstrap+guild")
- (version "2.0")
- (source (bootstrap-origin (package-source guile-2.0)))
- (native-inputs `(("bash" ,(bootstrap-executable "bash" (%current-system)))
- ("tar" ,(bootstrap-executable "tar" (%current-system)))
- ("xz" ,(bootstrap-executable "xz" (%current-system)))
- ("guile" ,%bootstrap-guile)))
- (build-system trivial-build-system)
- (arguments
- `(#:guile ,%bootstrap-guile
- #:modules ((guix build utils))
- #:builder (begin
- (use-modules (guix build utils))
- (let ((guile-source (assoc-ref %build-inputs "source"))
- (bin (string-append (getcwd) "/bin"))
- (tar (assoc-ref %build-inputs "tar"))
- (xz (assoc-ref %build-inputs "xz")))
- (mkdir-p bin)
- (setenv "PATH" bin)
- (with-directory-excursion bin
- (copy-file tar "tar")
- (copy-file xz "xz")
- (setenv "PATH" bin))
- (let* ((out (assoc-ref %outputs "out"))
- (out-bin (string-append out "/bin"))
- (guile (assoc-ref %build-inputs "guile"))
- (bash (assoc-ref %build-inputs "bash")))
- (mkdir-p out-bin)
- (with-directory-excursion out-bin
- (symlink (string-append guile "/bin/guile")
- "guile")
- (invoke "tar" "--strip-components=2"
- "-xvf" guile-source
- (string-append "guile-"
- ,(package-version guile-2.0)
- "/meta/guild.in"))
- (copy-file "guild.in" "guild")
- (substitute* "guild"
- (("#!/bin/sh") (string-append "#! " bash))
- (("@installed_guile@") (string-append out-bin "/guile")))
- (chmod "guild" #o555)))))))
- (synopsis "Bootstrap Guile plus Guild")
- (description "Bootstrap Guile with added Guild")
- (home-page #f)
- (license (package-license guile-2.0))
- (native-search-paths
- (list (search-path-specification
- (variable "GUILE_LOAD_PATH")
- (files '("share/guile/site/2.0")))
- (search-path-specification
- (variable "GUILE_LOAD_COMPILED_PATH")
- (files '("lib/guile/2.0/site-ccache")))))))
-
(define bootar
(package
(name "bootar")