summaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-11 19:28:01 +0200
committerMarius Bakke <marius@gnu.org>2022-08-11 22:39:14 +0200
commitf7e8be231806a904e6817e8ab3404b32f2511db2 (patch)
tree4966779562a7b5a881c533c2732e8ce133641552 /gnu/packages/commencement.scm
parente9afd8a00595fdc07a0df3a7680cecdb8aa16df7 (diff)
gnu: texinfo: Fix @headings regression.
* gnu/packages/patches/texinfo-headings-single.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/texinfo.scm (texinfo)[source](patches): New field. * gnu/packages/commencement.scm (texinfo-boot0)[source]: Use BOOTSTRAP-ORIGIN.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index da6bb03553..0dbd39382e 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2609,6 +2609,7 @@ memoized as a function of '%current-system'."
;; Also, use (%BOOT0-INPUTS) to avoid building Perl once more.
(package
(inherit texinfo)
+ (source (bootstrap-origin (package-source texinfo)))
(native-inputs '())
(inputs `(,@(%boot0-inputs)
("perl" ,perl-boot0)))