summaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-05-10 00:23:11 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-21 22:44:05 +0100
commit19c1c385c7af2c1209c93690cab778a328000125 (patch)
tree401cbfb8b05ca30905cc3fdbcabc004c81c46608 /gnu/packages/containers.scm
parente89bfb919e5b73ad917770c94327309254e82e85 (diff)
gnu: gvisor-tap-vsock: Remove references to go.
This is handled automatically by go-build-system, but (obviously) not by the gnu-build-system, so add the phase manually. * gnu/packages/containers.scm (gvisor-tap-vsock)[arguments]<#:phases>: Add 'remove-go-references phase. Change-Id: I5cef0bc03dfa7f219bdfec4226d0e7772401a5a5 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 29b390758b..c9e94a07ea 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -26,6 +26,7 @@
(define-module (gnu packages containers)
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix modules)
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
@@ -388,6 +389,9 @@ configure network interfaces in Linux containers.")
(list
#:make-flags `(list ,(string-append "GIT_VERSION=v" version))
#:test-target "test"
+ #:imported-modules
+ (source-module-closure `(,@%gnu-build-system-modules
+ (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -401,7 +405,9 @@ configure network interfaces in Linux containers.")
(invoke "rm" "-r" "test")))
(replace 'install
(lambda _
- (install-file "bin/gvproxy" (string-append #$output "/bin")))))))
+ (install-file "bin/gvproxy" (string-append #$output "/bin"))))
+ (add-after 'install 'remove-go-references
+ (@@ (guix build go-build-system) remove-go-references)))))
(native-inputs (list go-1.20))
(home-page "https://github.com/containers/gvisor-tap-vsock")
(synopsis "Network stack for virtualization based on gVisor")