summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorLu Hui <luhux76@gmail.com>2023-04-30 22:18:24 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-11 18:15:25 +0800
commitc2cac2e985251710061a877498fbd7186469c51d (patch)
treeb6e0f1a27834be26ff578db6f4c2e0aff0c54a95 /gnu/packages/cpp.scm
parentf2a5a326187e2e6e97a00ec6dad740e8528e0764 (diff)
gnu: ftxui: Update to 4.0.0.
* gnu/packages/cpp.scm (ftxui): Update to 4.0.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 023d1c0337..1a892d7b78 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2433,7 +2433,7 @@ queues, resource pools, strings, etc.
(define-public ftxui
(package
(name "ftxui")
- (version "3.0.0")
+ (version "4.0.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2441,7 +2441,7 @@ queues, resource pools, strings, etc.
(commit (string-append "v" version))))
(sha256
(base32
- "10a4yw2h29kixxyhll6cvrwyscsvz9asxry857a9l8nqvbhs946s"))
+ "01h59ln8amsj6ymxmsxhmslld2yp003n82fg3mphgkrh6lf22h6y"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs (list googletest))
@@ -2459,9 +2459,8 @@ queues, resource pools, strings, etc.
;; Disable benchmarks for a while as they require bundled Google
;; benchmark and when the 'googlebenchmark' is unbundled, there's
;; a CMake configuration error.
- (substitute* "cmake/ftxui_benchmark.cmake"
- (("NOT WIN32")
- "FALSE")))) )))
+ ;; TODO: fetch googlebenchmark then renable test
+ (truncate-file "cmake/ftxui_benchmark.cmake" 0))))))
(home-page "https://github.com/ArthurSonzogni/FTXUI")
(synopsis "C++ Functional Terminal User Interface")
(description