summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-16 03:33:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-17 04:45:29 +0100
commitc7e8bfe2ff05af55bbe1207b0e50077689e5aeb2 (patch)
treeff965c38758989b8dc3c80b15f5999594a06c771 /gnu/packages/cpp.scm
parent902e944ef7a65c026078b3d45a2ac5148cd45103 (diff)
gnu: xsimd: Define SIMD.
* gnu/packages/cpp.scm (xsimd)[description]: Expand the @acronym.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 1e2cd55afa..f0d8cd2a40 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -212,11 +212,12 @@ combination of these streams.")
`(("googletest" ,googletest)))
(home-page "https://github.com/QuantStack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
- (description "xsimd provides a unified means for using SIMD features for
-library authors. Namely, it enables manipulation of batches of numbers with
-the same arithmetic operators as for single values. It also provides
-accelerated implementation of common mathematical functions operating on
-batches.")
+ (description
+ "xsimd provides a unified means for using @acronym{SIMD, single instruction
+multiple data} features for library authors. Namely, it enables manipulation of
+batches of numbers with the same arithmetic operators as for single values.
+It also provides accelerated implementation of common mathematical functions
+operating on batches.")
(license license:bsd-3)))
(define-public chaiscript