summaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-02-24 14:13:13 +0000
committerLeo Famulari <leo@famulari.name>2021-02-25 14:41:41 -0500
commitf16168744e8d5ab30cc77919cc06389c3f4a6abe (patch)
tree0861e8f100dfa06a67c7c5d738c131e1fa1a63d2 /gnu/packages/cpp.scm
parenta2ece4da1fdccb9e94681e38a3f3a79b0d43e061 (diff)
gnu: Add caf.
* gnu/packages/cpp.scm (caf): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 685dc02fca..659eb1cdeb 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -954,3 +954,29 @@ conversions to and from strings, iteration and related functionality.")
feature set with a simple and intuitive interface.")
(home-page "https://cliutils.github.io/CLI11/book/")
(license license:bsd-3)))
+
+(define-public caf
+ (package
+ (name "caf")
+ (version "0.18.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/actor-framework/actor-framework")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c3spd6vm1h9qhlk5c4fdwi6nbqx5vwz2zvv6qp0rj1hx6xpq3cx"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DCAF_ENABLE_EXAMPLES=OFF")))
+ (inputs
+ `(("openssl" ,openssl)))
+ (synopsis "C++ implementation of the actor model")
+ (description "The C++ Actor Framework (CAF) offers a high-level C++17
+programming environment using the actor model for concurrent, distributed
+computation.")
+ (home-page "https://www.actor-framework.org/")
+ (license license:bsd-3)))