summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:32:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commit1de36ea8d756113f4c2f86e4685c21b058125376 (patch)
tree959fb193bf657b1faf934191483a81f0392fa385 /gnu/packages/cran.scm
parent411f3f1ffe8ec17bd7fea624ff2284786de36c14 (diff)
gnu: Add r-bestnormalize.
* gnu/packages/cran.scm (r-bestnormalize): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 81b01d4ad1..ec07e401fa 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1084,6 +1084,48 @@ and compare against other CPUs. Also provides functions for obtaining system
specifications, such as RAM, CPU type, and R version.")
(license license:gpl2+)))
+(define-public r-bestnormalize
+ (package
+ (name "r-bestnormalize")
+ (version "1.8.3")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bestNormalize" version))
+ (sha256
+ (base32
+ "107z16vx6k31ln5ppxixjgagrzrjwlrk13689lq2s90x4k2pgmkh"))))
+ (properties `((upstream-name . "bestNormalize")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-butcher
+ r-doparallel
+ r-dorng
+ r-dplyr
+ r-foreach
+ r-lambertw
+ r-nortest
+ r-purrr
+ r-recipes
+ r-tibble))
+ (native-inputs (list r-knitr))
+ (home-page "https://petersonr.github.io/bestNormalize/")
+ (synopsis "Normalizing transformation functions")
+ (description
+ "Estimate a suite of normalizing transformations, including a new
+adaptation of a technique based on ranks which can guarantee normally
+distributed transformed data if there are no ties: @dfn{ordered quantile
+normalization} (ORQ). ORQ normalization combines a rank-mapping approach with
+a shifted logit approximation that allows the transformation to work on data
+outside the original domain. It is also able to handle new data within the
+original domain via linear interpolation. The package is built to estimate
+the best normalizing transformation for a vector consistently and accurately.
+It implements the Box-Cox transformation, the Yeo-Johnson transformation,
+three types of Lambert WxF transformations, and the ordered quantile
+normalization transformation. It estimates the normalization efficacy of
+other commonly used transformations, and it allows users to specify custom
+transformations or normalization statistics. Finally, functionality can be
+integrated into a machine learning workflow via recipes.")
+ (license license:gpl3)))
+
(define-public r-bezier
(package
(name "r-bezier")