summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-02 15:12:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-02 15:12:01 +0200
commit20f9473532dd288c536581df2573ece2079f7a27 (patch)
tree0861235205585a9dc5748171e850a884c7c6396c /gnu/packages/cran.scm
parent03858a79084515eb808bb3275cb2078a4dde3909 (diff)
gnu: Add r-phylotools.
* gnu/packages/cran.scm (r-phylotools): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fc7fd0467e..e8f21b7567 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14592,6 +14592,27 @@ library which allows parsing of NEXUS, Newick and other phylogenetic tree
methods, incorporating one or more trees and trait data.")
(license license:gpl2+)))
+(define-public r-phylotools
+ (package
+ (name "r-phylotools")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "phylotools" version))
+ (sha256
+ (base32
+ "1dhk1ncp5zi4zl1xfnjz64v983dm7bq7iimfjin80j0bdcpps44w"))))
+ (properties `((upstream-name . "phylotools")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape))
+ (home-page "https://github.com/helixcn/phylotools")
+ (synopsis "Phylogenetic tools for eco-phylogenetics")
+ (description
+ "This package provides a collection of tools for building RAxML
+supermatrix using PHYLIP or aligned FASTA files. These functions will be
+useful for building large phylogenies using multiple markers.")
+ (license license:gpl2)))
+
(define-public r-rnexml
(package
(name "r-rnexml")