summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-28 00:37:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 12:19:59 +0100
commit3efea1fc14bc2b7b95116676e0352119e3709392 (patch)
tree44648ec33fb35f7d3e75e17276469bd572b3061d /gnu/packages/cran.scm
parent5fdf7e9ab943e42ec8096d310791148652c82079 (diff)
gnu: Add r-n2r.
* gnu/packages/cran.scm (r-n2r): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6db37eddf0..e04b3e320f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8334,6 +8334,32 @@ features:
")
(license license:gpl3)))
+(define-public r-n2r
+ (package
+ (name "r-n2r")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "N2R" version))
+ (sha256
+ (base32 "12bv7xx6j6222qgpv6g61i68017fz0x6fjg9a9k5yhgw3zk05hpk"))))
+ (properties `((upstream-name . "N2R")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-matrix
+ r-rcpp
+ r-rcppeigen
+ r-rcppspdlog))
+ (home-page "https://github.com/kharchenkolab/N2R")
+ (synopsis "Fast and scalable approximate k-Nearest Neighbor search methods")
+ (description
+ "This package implements methods to perform fast approximate K-nearest
+neighbor search on the input matrix. The algorithm is based on the N2
+implementation of an approximate nearest neighbor search using hierarchical
+@acronym{NSW, Navigable Small World} graphs.")
+ (license license:asl2.0)))
+
(define-public r-network
(package
(name "r-network")