summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 16:46:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 15:38:51 +0100
commit5aa7e882fa3f198fa8e108827162d71b0229033c (patch)
tree7aaab11473b122ef93f9a065c16fa54254c609b9 /gnu/packages/cran.scm
parentf5f440312d848e12463f0c6f7510a86b623a9e27 (diff)
gnu: Add r-ggplot-multistats.
* gnu/packages/cran.scm (r-ggplot-multistats): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c9dfafa9b1..3190cee592 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18706,3 +18706,31 @@ finding peaks in spectra, converting humidity measures.")
"This package allows you to create Q-Q and Manhattan plots for GWAS data
from PLINK results.")
(license license:gpl3)))
+
+(define-public r-ggplot-multistats
+ (package
+ (name "r-ggplot-multistats")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggplot.multistats" version))
+ (sha256
+ (base32
+ "1afzfa86vc484bcwpg7m1ky03jpax584rigzgai8w06pifkmz0il"))))
+ (properties
+ `((upstream-name . "ggplot.multistats")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-hexbin" ,r-hexbin)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)))
+ (home-page "https://github.com/flying-sheep/ggplot.multistats")
+ (synopsis "Multiple summary statistics for binned stats/geometries")
+ (description
+ "This package provides the ggplot binning layer @code{stat_summaries_hex()},
+which functions similar to its singular form, but allows the use of multiple
+statistics per bin. Those statistics can be mapped to multiple bin
+aesthetics.")
+ (license license:gpl3)))