summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-11-03 15:42:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-03 22:49:10 +0100
commit75ce5b04661d848840427657a52d7e52e305539e (patch)
treea7e1b845a567e4336dee2ff06cccf0f4d2cffff8 /gnu/packages/cran.scm
parent4f85beac2d8723752a15cb55a8a69085001c5185 (diff)
gnu: Add r-collapse.
* gnu/packages/cran.scm (r-collapse): New variable. Change-Id: Ib6690a85987e14930057ed960fdd229706b0c35d
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30f28f6adc..ecf9f0f96e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -388,6 +388,38 @@ for the creation a standard CONSORT diagram. Human effort by supplying text
labels on the node can also be achieved.")
(license license:expat)))
+(define-public r-collapse
+ (package
+ (name "r-collapse")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "collapse" version))
+ (sha256
+ (base32 "16y4qxqr4k04690xn8s6c9fr3igpk34pgxygxkc41gc1na0ym37v"))))
+ (properties `((upstream-name . "collapse")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp))
+ (native-inputs (list r-knitr))
+ (home-page "https://sebkrantz.github.io/collapse/")
+ (synopsis "Advanced and fast data transformation")
+ (description
+ "This is a C/C++ based package for advanced data transformation and
+statistical computing in R that is extremely fast, class-agnostic, robust and
+programmer friendly. Core functionality includes a rich set of S3 generic
+grouped and weighted statistical functions for vectors, matrices and data
+frames, which provide efficient low-level vectorizations, @code{OpenMP}
+multithreading, and skip missing values by default. These are integrated with
+fast grouping and ordering algorithms (also callable from C), and efficient
+data manipulation functions. The package also provides a flexible and
+rigorous approach to time series and panel data in R. It further includes
+fast functions for common statistical procedures, detailed (grouped, weighted)
+summary statistics, powerful tools to work with nested data, fast data object
+conversions, functions for memory efficient R programming, and helpers to
+effectively deal with variable labels, attributes, and missing data.")
+ (license (list license:gpl2+))))
+
(define-public r-collections
(package
(name "r-collections")