summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorAfkhami, Navid <Navid.Afkhami@mdc-berlin.de>2024-06-19 10:46:37 +0000
committerAndreas Enge <andreas@enge.fr>2024-06-30 10:48:50 +0200
commite7777475cf0375f4224c97ec894f8b25e1ebae28 (patch)
treee0d1e43aa9607d2a1c3422d7127eac91b7894226 /gnu/packages/cran.scm
parentc070c060fd5edd317fa838feff2f1df6fe29830a (diff)
gnu: Add r-cutpointr.
* gnu/packages/cran.scm (r-cutpointr): New variable. Change-Id: I60e578fab1e251a526d90ce25dd1c3fc7ec4409d Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f42996d044..972e9d0395 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -704,6 +704,40 @@ to other implementations such a @code{purrr::partial()} the operators in
etc.")
(license license:gpl2+)))
+(define-public r-cutpointr
+ (package
+ (name "r-cutpointr")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cutpointr" version))
+ (sha256
+ (base32 "1qxnh20hs3bh9v04ls7gwwl7lfc6bwl8c88dn8lkcdqyp3nyr01j"))))
+ (properties `((upstream-name . "cutpointr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-foreach
+ r-ggplot2
+ r-gridextra
+ r-purrr
+ r-rcpp
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/thie1e/cutpointr")
+ (synopsis "Determine optimal cutpoints for binary classification")
+ (description
+ "This package estimates optimal cutpoints for binary classification metrics.
+It also validates performance using bootstrapping. Some methods for more
+robust cutpoint estimation are supported, e.g. a parametric method assuming
+normal distributions, bootstrapped cutpoints, and smoothing of the metric
+values per cutpoint using Generalized Additive Models. Various plotting
+functions are included.")
+ (license license:gpl3)))
+
(define-public r-datawizard
(package
(name "r-datawizard")