summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-23 16:21:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:35 +0300
commitc787f63ede5334f9ca885e8b0f3816cd0d7705d8 (patch)
tree2430a24240cd8db4aa242f6f60602abf88ae4e1f /gnu/packages/crates-graphics.scm
parentc07de7f91849b59e01598337329f961b2bd97e63 (diff)
gnu: Add rust-raw-window-handle-0.5.
* gnu/packages/crates-graphics.scm (rust-raw-window-handle-0.5): New variable. (rust-raw-window-handle-0.4): Inherit from rust-raw-window-handle-0.5.
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm26
1 files changed, 20 insertions, 6 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index b4bef2e0dd..afb55517e5 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2157,10 +2157,10 @@ AVIF format (powers the `cavif` tool).")
(list nasm)) ;for building rav1e
(inputs '())))
-(define-public rust-raw-window-handle-0.4
+(define-public rust-raw-window-handle-0.5
(package
(name "rust-raw-window-handle")
- (version "0.4.3")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
@@ -2168,17 +2168,31 @@ AVIF format (powers the `cavif` tool).")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hgvrqbr2b62zhq4ryv08h92mwis9v8f7j9pwcgxzlp7nswvw05q"))))
+ "1f9k10fgda464ia1b2hni8f0sa8i0bphdsbs3di032x80qgrmzzj"))))
(build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-cty" ,rust-cty-0.2))))
(home-page "https://github.com/rust-windowing/raw-window-handle")
(synopsis "Interoperability library for Rust Windowing applications")
(description
"Interoperability library for Rust Windowing applications.")
(license license:expat)))
+(define-public rust-raw-window-handle-0.4
+ (package
+ (inherit rust-raw-window-handle-0.5)
+ (name "rust-raw-window-handle")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "raw-window-handle" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hgvrqbr2b62zhq4ryv08h92mwis9v8f7j9pwcgxzlp7nswvw05q"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cty" ,rust-cty-0.2))))))
+
(define-public rust-raw-window-handle-0.3
(package
(inherit rust-raw-window-handle-0.4)