summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-20 13:09:17 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-03 22:06:35 +0100
commit28ba48959cb7ad384d958cf606d29a54f0bcdfd9 (patch)
treeeb5912244e162e62c77ba7d64c05d45b3f522889 /gnu/packages/crates-io.scm
parent69d22548f4abcfb4a83bd1c36acc278f1bce5467 (diff)
gnu: Add rust-cache-padded-1.
* gnu/packages/crates-io.scm (rust-cache-padded-1): New variable.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dedfcfe55d..d238dbf8e0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3716,6 +3716,29 @@ exposed as Reader/Writer streams.")
"The ChaCha family of stream ciphers.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-cache-padded-1
+ (package
+ (name "rust-cache-padded")
+ (version "1.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "cache-padded" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1fkdwv9vjazm6fs3s5v56mm4carwswdmw8fcwm9ygrcvihcya6k3"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/stjepang/cache-padded")
+ (synopsis "Prevent once piece of data invalidating other cached data")
+ (description
+ "In concurrent programming, sometimes it is desirable to make sure
+commonly accessed shared data is not all placed into the same cache line.
+Updating an atomic value invalides the whole cache line it belongs to, which
+makes the next access to the same cache line slower for other CPU cores. Use
+CachePadded to ensure updating one piece of data doesn't invalidate other
+cached data.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-cachedir-0.1
(package
(name "rust-cachedir")