summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-02-15 21:26:38 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:56 +0200
commit35fb6199f6cbbea8a4c8c901112cfa7c944f4401 (patch)
tree51b480b84fd0fc37ef62bdf11533efd8f511953c /gnu/packages/crates-io.scm
parent6e51c32f9e9c8fc81fa11e30229d4dcc8bda1ebe (diff)
gnu: Add rust-netlink-packet-route-0.19.
* gnu/packages/crates-io.scm (rust-netlink-packet-route-0.19): New variable. (rust-netlink-packet-route-0.18): Inherit from rust-netlink-packet-route-0.19. Change-Id: Id7adc5216b59ce46dda421d2866773fb35b55667 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 31 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bb7d786f31..f978f0b6cd 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39972,17 +39972,17 @@ that represent any netlink message for any sub-protocol.")
(description "Generic netlink packet types.")
(license license:expat)))
-(define-public rust-netlink-packet-route-0.18
+(define-public rust-netlink-packet-route-0.19
(package
(name "rust-netlink-packet-route")
- (version "0.18.1")
+ (version "0.19.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "netlink-packet-route" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1i9z89dy3p2jbs5rclvc6yxly81a4qwynrhyqv3hazj5pgxcv76x"))))
+ (base32 "1x4bjc97nq6ckvn25l8qysybf324jbinqx6s11vqrvmlfz6p3hbl"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t ; Cut the dependency tree
@@ -39998,11 +39998,36 @@ that represent any netlink message for any sub-protocol.")
("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))
(home-page "https://github.com/rust-netlink/netlink-packet-route")
(synopsis "Netlink packet types")
- (description "The netlink-packet-route crate is designed to abstract Netlink
-route protocol (rtnetlink) packet into Rust data types. The goal of this crate
-is saving netlink user from reading Kernel Netlink codes.")
+ (description "The netlink-packet-route crate is designed to abstract
+Netlink route protocol(rtnetlink) packet into Rust data types. The goal of
+this crate is saving netlink user from reading Kernel Netlink codes.")
(license license:expat)))
+(define-public rust-netlink-packet-route-0.18
+ (package
+ (inherit rust-netlink-packet-route-0.19)
+ (name "rust-netlink-packet-route")
+ (version "0.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "netlink-packet-route" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1i9z89dy3p2jbs5rclvc6yxly81a4qwynrhyqv3hazj5pgxcv76x"))))
+ (arguments
+ `(#:skip-build? #t ; Cut the dependency tree
+ #:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-netlink-packet-core" ,rust-netlink-packet-core-0.7)
+ ("rust-netlink-packet-utils" ,rust-netlink-packet-utils-0.5))
+ #:cargo-development-inputs
+ (("rust-netlink-sys" ,rust-netlink-sys-0.8)
+ ;("rust-pcap-file" ,rust-pcap-file-1)
+ ("rust-pretty-assertions" ,rust-pretty-assertions-0.7))))))
+
(define-public rust-netlink-packet-utils-0.5
(package
(name "rust-netlink-packet-utils")