summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-29 14:45:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-30 09:28:25 +0300
commitcca7cbe932f7c07b4a83e4f1d1bd22b06aa81494 (patch)
treeda4663b68d59648797b2e3ac74ebc1a91d7a8846 /gnu/packages/crates-io.scm
parent7158dc2d49329748c9ecd78bda3028ae53157a8e (diff)
gnu: Add rust-once-cell-1.
* gnu/packages/crates-io.scm (rust-once-cell-1): New variable. (rust-once-cell-1.2): Inherit from rust-once-cell-1.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 29 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7cb2fd40cb..a72334189c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16110,10 +16110,10 @@ You probably don't want to link to this crate directly; instead check out the
@code{onig} crate.")
(license license:expat)))
-(define-public rust-once-cell-1.2
+(define-public rust-once-cell-1
(package
(name "rust-once-cell")
- (version "1.2.0")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
@@ -16122,14 +16122,13 @@ You probably don't want to link to this crate directly; instead check out the
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vdz8xlg3r05w3wfjimnc347hgm54i5nrqf72r4mlp0fcdplh7w9"))))
+ "138n52yni5qym7ds8kxckvhdy4x0m0scy0gl74brmwsahmz1yqqb"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-parking-lot" ,rust-parking-lot-0.9))
+ `(#:cargo-inputs
+ (("rust-parking-lot" ,rust-parking-lot-0.10))
#:cargo-development-inputs
- (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.6)
+ (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.7)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-regex" ,rust-regex-1))))
(home-page "https://github.com/matklad/once_cell")
@@ -16138,6 +16137,29 @@ You probably don't want to link to this crate directly; instead check out the
"Single assignment cells and lazy values.")
(license (list license:expat license:asl2.0))))
+(define-public rust-once-cell-1.2
+ (package
+ (inherit rust-once-cell-1)
+ (name "rust-once-cell")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "once-cell" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vdz8xlg3r05w3wfjimnc347hgm54i5nrqf72r4mlp0fcdplh7w9"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-parking-lot" ,rust-parking-lot-0.9))
+ #:cargo-development-inputs
+ (("rust-crossbeam-utils" ,rust-crossbeam-utils-0.6)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-regex" ,rust-regex-1))))))
+
(define-public rust-once-cell-0.1
(package
(inherit rust-once-cell-1.2)