summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-29 19:42:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-29 21:14:39 +0200
commit36d6b1ac5f43c3746b73e1cd612ba0cda8cee836 (patch)
tree962bf22b16f09919a1ff3f29722b868064115f12 /gnu/packages/crypto.scm
parentfea894d3270c1d768167d95e9b6c5bb8eed7291d (diff)
gnu: botan: Omit static library.
* gnu/packages/crypto.scm (botan)[arguments]: Add a "--disable-static" configure flag.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index dd2f76d2a1..f48fc23c1f 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -952,6 +952,8 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
(setenv "CXXFLAGS" "-O3")
(invoke "python" "./configure.py"
(string-append "--prefix=" out)
+ "--disable-static"
+
;; Otherwise, the `botan` executable cannot find
;; libbotan.
(string-append "--ldflags=-Wl,-rpath=" lib)