summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-07 11:04:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-07 14:19:08 +0200
commitd9dfbf886ddbb92dfdaa118bb9765e78aad5c53a (patch)
tree2732020de20a38c09b66a60b0cb36022799f7c2e /gnu/packages/crypto.scm
parentb949f34f31a045eb0fb242b81a223178fb6994d3 (diff)
parent49922efb11da0f0e9d4f5979d081de5ea8c99d25 (diff)
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm57
1 files changed, 0 insertions, 57 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 917e88b44c..d26708f3ce 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -399,63 +399,6 @@ secure operations. ")
(license (list license:lgpl2.1+ ; the files keyutils.*
license:gpl2+)))) ; the rest
-;; There is no release candidate but commits point out a version number,
-;; furthermore no tarball exists.
-(define-public eschalot
- (let ((commit "0bf31d88a11898c19b1ed25ddd2aff7b35dbac44")
- (revision "1"))
- (package
- (name "eschalot")
- (version (string-append "1.2.0-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/schnabear/eschalot")
- (commit commit)))
- (file-name (string-append name "-" version))
- (sha256
- (base32
- "0lj38ldh8vzi11wp4ghw4k0fkwp0s04zv8k8d473p1snmbh7mx98"))))
- (inputs
- `(("openssl" ,openssl-1.0))) ; for openssl/{bn,pem,rsa,sha}.h
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "INSTALL=" "install"))
- ;; XXX: make test would run a !VERY! long hashing of names with the use
- ;; of a wordlist, the amount of computing time this would waste on build
- ;; servers is in no relation to the size or importance of this small
- ;; application, therefore we run our own tests on eschalot and worgen.
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda _
- (invoke "./worgen" "8-12" "top1000.txt" "3-10" "top400nouns.txt"
- "3-6" "top150adjectives.txt" "3-6")
- (invoke "./eschalot" "-r" "^guix|^GuixSystem")
- (invoke "./eschalot" "-r" "^gnu|^free")
- (invoke "./eschalot" "-r" "^cyber|^hack")
- (invoke "./eschalot" "-r" "^troll")))
- ;; Make install can not create the bin dir, create it.
- (add-before 'install 'create-bin-dir
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (mkdir-p bin)
- #t))))))
- (home-page "https://github.com/schnabear/eschalot")
- (synopsis "Tor hidden service name generator")
- (description
- "Eschalot is a tor hidden service name generator, it allows one to
-produce customized vanity .onion addresses using a brute-force method. Searches
-for valid names can be run with regular expressions and wordlists. For the
-generation of wordlists the included tool @code{worgen} can be used. There is
-no man page, refer to the home page for usage details.")
- (license (list license:isc license:expat)))))
-
(define-public ssss
(package
(name "ssss")