summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-09-21 08:35:56 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-21 14:21:44 +0000
commit94006cc29cbfb8ea53f68cb335358e1b6d6692c1 (patch)
tree1cb70718d0d99f92454de1cce6d63a1f5a5ab3da /gnu/packages/databases.scm
parentfa6a1f52b2a1e55770ac073884cb7146749d3e63 (diff)
gnu: mysql: Add wrapper around mysql_config.
Fixes <https://bugs.gnu.org/23045>. * gnu/packages/databases.scm (mysql): Add a 'wrap-mysql_helpers phase to wrap 'mysql_config' and 'mysqld_safe'. [inputs]: Add 'coreutils', 'gawk', 'grep', 'procps' and 'sed'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1fcc1569f0..a27fd637eb 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -53,6 +53,7 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Alexandre Hannud Abdo <abdo@member.fsf.org>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -90,6 +91,7 @@
#:use-module (gnu packages emacs)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gawk)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -695,6 +697,29 @@ auto-completion and syntax highlighting.")
(for-each delete-file
(find-files (string-append out "/bin")
"_embedded$"))
+ #t)))
+ (add-after
+ 'install 'wrap-mysql_helpers
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (awk (assoc-ref inputs "gawk"))
+ (coreutils (assoc-ref inputs "coreutils"))
+ (grep (assoc-ref inputs "grep"))
+ (ps (assoc-ref inputs "procps"))
+ (sed (assoc-ref inputs "sed")))
+ (wrap-program (string-append bin "/mysql_config")
+ `("PATH" ":" suffix
+ (,(string-append awk "/bin")
+ ,(string-append coreutils "/bin")
+ ,(string-append sed "/bin"))))
+ (wrap-program (string-append bin "/mysqld_safe")
+ `("PATH" ":" suffix
+ (,(string-append awk "/bin")
+ ,(string-append coreutils "/bin")
+ ,(string-append grep "/bin")
+ ,(string-append ps "/bin")
+ ,(string-append sed "/bin"))))
#t))))))
(native-inputs
`(("bison" ,bison)
@@ -702,11 +727,16 @@ auto-completion and syntax highlighting.")
("pkg-config" ,pkg-config)))
(inputs
`(("boost" ,boost-for-mysql)
+ ("coreutils" ,coreutils)
+ ("gawk" ,gawk)
+ ("grep" ,grep)
("libaio" ,libaio)
("libtirpc" ,libtirpc)
("ncurses" ,ncurses)
("openssl" ,openssl)
+ ("procps" ,procps)
("rpcsvc-proto" ,rpcsvc-proto) ; rpcgen
+ ("sed" ,sed)
("zlib" ,zlib)))
(home-page "https://www.mysql.com/")
(synopsis "Fast, easy to use, and popular database")