summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:59:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 15:59:30 -0400
commit990a4822f1cb45c1470fe38cbf17fd7bb54d0088 (patch)
tree1c1ff41c9264fe5af5ee0b8723d1e367e958c051 /gnu/packages/databases.scm
parent91db77c955cc7ef95dd8b535e40d6b4cf28669ec (diff)
parent3c6e220d8100281074c414a43c1efe9a01b53771 (diff)
Merge branch 'staging' into core-updates
Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm52
1 files changed, 28 insertions, 24 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a388e45697..545e652ec6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -258,17 +258,19 @@ ElasticSearch server")
(define-public firebird
(package
(name "firebird")
- (version "3.0.7")
+ (version "3.0.10")
(source
- (let ((revision "33374-0"))
+ (let ((revision "33601-0"))
(origin
(method url-fetch)
(uri (string-append "https://github.com/FirebirdSQL/"
- "firebird/releases/download/R"
- (string-replace-substring version "." "_") "/"
+ "firebird/releases/download/v"
+ version "/"
"Firebird-" version "." revision ".tar.bz2"))
(sha256
- (base32 "0xpy1bncz36c6n28y7kllm1dkrdkn4vb4gw2n43f2351mznmrf5c"))
+ (base32 "0h033xj1kxwgvdv4ncm6kk0mqybvvn203gf88xcv3avys9hbnf4i"))
+ (patches (search-patches "firebird-riscv64-support-pt1.patch"
+ "firebird-riscv64-support-pt2.patch"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -290,8 +292,7 @@ ElasticSearch server")
"doc/Firebird-3-QuickStart.pdf"
(string-append "doc/Firebird-" ,version
"-ReleaseNotes.pdf")
- "doc/README.SecureRemotePassword.html"))
- #t)))))
+ "doc/README.SecureRemotePassword.html")))))))
(build-system gnu-build-system)
(outputs (list "debug" "out"))
(arguments
@@ -324,13 +325,19 @@ ElasticSearch server")
(srfi srfi-26))
#:phases
(modify-phases %standard-phases
+ ,@(if (target-riscv64?)
+ `((add-before 'bootstrap 'force-bootstrap
+ (lambda _
+ (delete-file "configure")
+ ;; This file prevents automake from running.
+ (delete-file "autogen.sh"))))
+ '())
(add-after 'unpack 'use-system-boost
(lambda _
(substitute* "src/include/firebird/Message.h"
(("\"\\./impl/boost/preprocessor/seq/for_each_i\\.hpp\"")
"<boost/preprocessor/seq/for_each_i.hpp>")
- (("FB_BOOST_") "BOOST_"))
- #t))
+ (("FB_BOOST_") "BOOST_"))))
(add-after 'unpack 'patch-installation
(lambda _
(substitute*
@@ -358,27 +365,23 @@ ElasticSearch server")
;; These promote proprietary workflows not relevant on Guix.
(for-each delete-file-recursively
- (find-files "doc" "README\\.(build\\.msvc|NT|Win)"))
- #t))
+ (find-files "doc" "README\\.(build\\.msvc|NT|Win)"))))
(add-after 'configure 'delete-init-scripts
(lambda _
- (delete-file-recursively "gen/install/misc")
- #t))
+ (delete-file-recursively "gen/install/misc")))
(add-before 'build 'set-build-environment-variables
(lambda _
;; ‘isql’ needs to run & find libfbclient.so during the build.
;; This doubles as a rudimentary test in lieu of a test suite.
(setenv "LD_LIBRARY_PATH"
- (string-append (assoc-ref %build-inputs "icu4c") "/lib"))
- #t))
+ (string-append (assoc-ref %build-inputs "icu4c") "/lib"))))
(add-before 'install 'keep-embedded-debug-symbols
(lambda _
;; Let the gnu-build-system separate & deal with them later.
;; XXX Upstream would use ‘--strip-unneeded’, shaving a whole
;; megabyte off Guix's 7.7M libEngine12.so, for example.
(substitute* "gen/Makefile.install"
- (("readelf") "false"))
- #t))
+ (("readelf") "false"))))
(add-after 'install 'prune-undesirable-files
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -389,12 +392,15 @@ ElasticSearch server")
;; Delete (now-)empty directories.
(for-each rmdir
(list "include/firebird/impl"
- "lib/firebird/plugins/udr"))
- #t)))))))
+ "lib/firebird/plugins/udr")))))))))
+ (native-inputs
+ (if (target-riscv64?)
+ (list autoconf automake libtool)
+ '()))
(inputs
(list boost
editline
- icu4c-67
+ icu4c
libtommath
ncurses
zlib))
@@ -417,8 +423,6 @@ Firebird can also be embedded into stand-alone applications that don't want or
need a full client & server. Used in this manner, it offers richer SQL support
than SQLite as well as the option to seamlessly migrate to a client/server
database later.")
- (properties
- `((lint-hidden-cve . ("CVE-2017-6369"))))
(license
;; See doc/license/README.license.usage.txt for rationale & details.
(list license:bsd-3 ; src/common/sha2/
@@ -4137,7 +4141,7 @@ the SQL language using a syntax that reflects the resulting query.")
(define-public apache-arrow
(package
(name "apache-arrow")
- (version "8.0.0")
+ (version "9.0.0")
(source
(origin
(method git-fetch)
@@ -4147,7 +4151,7 @@ the SQL language using a syntax that reflects the resulting query.")
(file-name (git-file-name name version))
(sha256
(base32
- "1gwiflk72pq1krc0sjzabypmh7slfyf7ak71fiypy3xgzw8a777c"))))
+ "1l76q7944jyx22vjkk12hxb3nadgiivc3x8ml4mg619v9xxagc2v"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f