summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-13 13:45:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-13 13:45:35 -0400
commitc02257b6d1bade6efa528271b55bf8d8ab7b0296 (patch)
tree616bad69b4bacba24c5105336bc282626fcbd114 /gnu/packages/databases.scm
parentc371555a4b46a5c9288f54753b0f158f9c4b8abc (diff)
parent0fe2c78cac19acfb46c3bc365075293e51e0e5aa (diff)
Merge staging branch.
Conflicts resolved in: gnu/packages/engineering.scm gnu/packages/gnuzilla.scm gnu/packages/photo.scm
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm108
1 files changed, 30 insertions, 78 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0dc2e38e38..0f2dce00a1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -133,6 +133,7 @@
#:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
@@ -900,7 +901,7 @@ Language.")
(define-public mariadb
(package
(name "mariadb")
- (version "10.5.12")
+ (version "10.10.2")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.mariadb.com/MariaDB"
@@ -908,21 +909,11 @@ Language.")
version ".tar.gz"))
(sha256
(base32
- "1gg4h9ahmk78cx01zyw0fqr6hhd78fsyhs0s34p3gi9hkak1qkxb"))
+ "1ciw7y08wms9g3hzhyria49r1b9n5wpbhkndazv95d925c8x1jsp"))
(modules '((guix build utils)))
(snippet
'(begin
- ;; Delete bundled snappy and xz.
- (delete-file-recursively "storage/tokudb/PerconaFT/third_party")
- (substitute* "storage/tokudb/PerconaFT/CMakeLists.txt"
- ;; This file checks that the bundled sources are present and
- ;; declares build procedures for them.
- (("^include\\(TokuThirdParty\\)") ""))
- (substitute* "storage/tokudb/PerconaFT/ft/CMakeLists.txt"
- ;; Don't attempt to use the procedures we just removed.
- ((" build_lzma build_snappy") ""))
-
- ;; Preserve CMakeLists.txt for these.
+ ;; Delete bundled libraries, but preserve CMakeLists.txt.
(for-each (lambda (file)
(unless (string-suffix? "CMakeLists.txt" file)
(delete-file file)))
@@ -934,21 +925,10 @@ Language.")
`(#:configure-flags
(list
"-DBUILD_CONFIG=mysql_release"
- ;; Linking with libarchive fails, like this:
-
- ;; ld: /gnu/store/...-libarchive-3.2.2/lib/libarchive.a(archive_entry.o):
- ;; relocation R_X86_64_32 against `.bss' can not be used when
- ;; making a shared object; recompile with -fPIC
-
- ;; For now, disable the features that that use libarchive (xtrabackup).
- "-DWITH_LIBARCHIVE=OFF"
-
- ;; Disable the TokuDB engine, because its test suite frequently fails,
- ;; and loading it crashes the server: <https://bugs.gnu.org/35521>.
- "-DTOKUDB_OK=OFF"
;; Ensure the system libraries are used.
"-DWITH_JEMALLOC=yes"
+ "-DWITH_LIBFMT=system"
"-DWITH_PCRE=system"
"-DWITH_SSL=system"
"-DWITH_ZLIB=system"
@@ -988,14 +968,6 @@ Language.")
#:parallel-tests? ,(target-x86-64?)
#:phases
(modify-phases %standard-phases
- ,@(if (target-ppc32?)
- `((add-after 'unpack 'apply-libatomics-patch
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((patch-file
- (assoc-ref inputs
- "mariadb-link-libatomic.patch")))
- (invoke "patch" "-p1" "-i" patch-file)))))
- '())
(add-after 'unpack 'adjust-output-references
(lambda _
;; The build system invariably prepends $CMAKE_INSTALL_PREFIX
@@ -1031,6 +1003,9 @@ Language.")
"main.explain_non_select"
"main.upgrade_MDEV-19650"
"roles.acl_statistics"
+ "main.stat_tables_innodb"
+ "main.stat_tables"
+ "main.mysql_upgrade"
;; Probably same as above, test failure reported upstream:
;; <https://jira.mariadb.org/browse/MDEV-26320>.
@@ -1057,36 +1032,19 @@ Language.")
disabled-tests)
(close-port unstable-tests)
- ;; XXX: These fail because they expect a latin1 charset and
- ;; collation. See <https://jira.mariadb.org/browse/MDEV-21264>.
- (substitute* '("mysql-test/main/gis_notembedded.result"
- "mysql-test/main/system_mysql_db.result")
- (("latin1_swedish_ci") "utf8_general_ci")
- (("\tlatin1") "\tutf8"))
-
(substitute* "mysql-test/suite/binlog/t/binlog_mysqlbinlog_stop_never.test"
(("/bin/bash")
(which "bash")))
- (substitute* "mysql-test/mysql-test-run.pl"
+ (substitute* "mysql-test/mariadb-test-run.pl"
(("/bin/ls") (which "ls"))
(("/bin/sh") (which "sh"))))))
- (add-before 'configure 'disable-plugins
- (lambda _
- (let ((disable-plugin (lambda (name)
- (call-with-output-file
- (string-append "plugin/" name
- "/CMakeLists.txt")
- (lambda (port)
- (format port "\n")))))
- (disabled-plugins '(;; XXX: Causes a test failure.
- "disks")))
- (for-each disable-plugin disabled-plugins))))
(replace 'check
(lambda* (#:key (tests? #t) parallel-tests? #:allow-other-keys)
(if tests?
(with-directory-excursion "mysql-test"
- (invoke "./mtr" "--verbose"
+ (invoke "./mariadb-test-run"
+ "--verbose"
"--retry=3"
"--suite=main"
"--testcase-timeout=40"
@@ -1100,13 +1058,12 @@ Language.")
"--skip-rpl"
"--skip-test-list=unstable-tests"))
(format #t "test suite not run~%"))))
- (add-after
- 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
(dev (assoc-ref outputs "dev"))
(lib (assoc-ref outputs "lib"))
- (openssl (assoc-ref inputs "openssl")))
+ (openssl (dirname (search-input-file inputs "lib/libssl.so"))))
(substitute* (list (string-append out "/bin/mariadb-install-db")
(string-append out "/bin/mysql_install_db"))
(("basedir=\"\"")
@@ -1133,7 +1090,7 @@ Language.")
(mkdir-p (string-append dev "/lib"))
(rename-file (string-append lib "/lib/pkgconfig")
(string-append dev "/lib/pkgconfig"))
- (rename-file (string-append lib "/bin/mariadb_config")
+ (rename-file (string-append out "/bin/mariadb_config")
(string-append dev "/bin/mariadb_config"))
(rename-file (string-append out "/bin/mysql_config")
(string-append dev "/bin/mysql_config"))
@@ -1144,25 +1101,20 @@ Language.")
(substitute* (list (string-append dev "/bin/mysql_config")
(string-append dev "/lib/pkgconfig/mariadb.pc"))
(("-lssl -lcrypto" all)
- (string-append "-L" openssl "/lib " all)))))))))
+ (string-append "-L" openssl " " all)))))))))
(native-inputs
- (if (target-ppc32?)
- `(("mariadb-link-libatomic.patch"
- ,(search-patch "mariadb-link-libatomic.patch"))
- ("patch" ,patch)
- ("bison" ,bison)
- ("perl" ,perl))
- (list bison perl)))
+ (list bison perl))
(inputs
- `(("jemalloc" ,jemalloc)
- ("libaio" ,libaio)
- ("libxml2" ,libxml2)
- ("ncurses" ,ncurses)
- ("openssl" ,openssl-1.1)
- ("pam" ,linux-pam)
- ("pcre2" ,pcre2)
- ("xz" ,xz)
- ("zlib" ,zlib)))
+ (list fmt
+ jemalloc
+ libaio
+ libxml2
+ ncurses
+ openssl
+ linux-pam
+ pcre2
+ xz
+ zlib))
;; The test suite is very resource intensive and can take more than three
;; hours on a x86_64 system. Give slow and busy machines some leeway.
(properties '((timeout . 64800))) ;18 hours
@@ -1288,14 +1240,14 @@ pictures, sounds, or video.")
(package
(inherit postgresql-15)
(name "postgresql")
- (version "14.4")
+ (version "14.6")
(source (origin
(inherit (package-source postgresql-15))
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "0slg7ld5mldmv3pn1wxxwglm4s3xc6c91ixx24apj713qlvn4fy2"))))))
+ "08nzkq321fzfi8ba8gck9zxxg7xvv8vz3mbl4avrmlq933y4122h"))))))
(define-public postgresql-13
(package