summaryrefslogtreecommitdiff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-16 14:51:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-19 13:12:28 +0200
commit1b16ae2c7a267f72226bd9281d02fcb1da971448 (patch)
treec762d5c2a2cd62c5f1476644e8f1d0c74c646066 /gnu/packages/debug.scm
parent45a82f08f47dc46acf007b1e7292c48263f2d93a (diff)
gnu: libbacktrace: Update to 1.0-2.cdb64b6.
* gnu/packages/debug.scm (libbacktrace): Update to 1.0-2.cdb64b6. [arguments]: Disable parallel tests.
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index fe00cb5705..f3279be919 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
;;; Copyright © 2023 Andy Tai <atai@atai.org>
+;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -688,8 +689,8 @@ fun.")
(define-public libbacktrace
;; There are no releases nor tags.
- (let ((revision "1")
- (commit "5009c113981431ae1843ebd29d6ad24eb32fc1b2"))
+ (let ((revision "2")
+ (commit "cdb64b688dda93bbbacbc2b1ccf50ce9329d4748"))
(package
(name "libbacktrace")
(version (git-version "1.0" revision commit))
@@ -701,10 +702,11 @@ fun.")
(file-name (git-file-name name version))
(sha256
(base32
- "0663zjpfpnsyv9h3pbp7cgmg9gz79n68bqpdl97y6i0jsx93v1zg"))))
+ "0iwd41pgr2nxlmghqdfwfwxac27jbqxwxp07jihhq85a8s3igjgr"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags '("CFLAGS=-fPIC")))
+ `(#:parallel-tests? #f ;spurious failures when testing in parallel
+ #:make-flags '("CFLAGS=-fPIC")))
(home-page "https://github.com/ianlancetaylor/libbacktrace")
(synopsis "C library for producing symbolic backtraces")
(description "The @code{libbacktrace} library can be linked into a C/C++