summaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-18 23:07:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-18 23:07:40 +0100
commit7ba6d70e4528201151195e1ed2175ee4828bdb2f (patch)
tree3a95b7f107763f959c31187d394d3fabbf1501c5 /gnu/packages/diffoscope.scm
parent94c7f70faa0ba0409099b423df6534718d7518cc (diff)
parent6afea7489b76c8db58d4f389fdbedc7c2b8992bd (diff)
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 7fe7766a15..93630f3bb6 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -67,7 +67,7 @@
#:use-module (ice-9 match))
(define-public diffoscope
- (let ((version "131"))
+ (let ((version "133"))
(package
(name "diffoscope")
(version version)
@@ -79,7 +79,7 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0jai3kycjlrc64f4vg8yklri6ds1451qy6r6sw2646bhjr0gs233"))))
+ "0mvg5iyd3zjxsm66vax3qb89214j3wxcklvbhfrr8jlbzaw9pznh"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -90,6 +90,12 @@
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
+ ;; Patch in support for known tools
+ (add-after 'unpack 'add-known-tools
+ (lambda _
+ (substitute* "diffoscope/external_tools.py"
+ (("'debian': 'zstd'")
+ "'debian': 'zstd', 'guix': 'zstd'"))))
;; This test is broken because our `file` package has a
;; bug in berkeley-db file type detection.
(add-after 'unpack 'remove-berkeley-test
@@ -209,7 +215,8 @@
("wabt" ,wabt)
("xxd" ,xxd)
("xz" ,xz)
- ("zip" ,zip)))
+ ("zip" ,zip)
+ ("zstd" ,zstd)))
(home-page "https://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description