summaryrefslogtreecommitdiff
path: root/gnu/packages/display-managers.scm
diff options
context:
space:
mode:
authorSergio Pastor Pérez <sergio.pastorperez@outlook.es>2023-09-20 23:30:42 +0200
committerLudovic Courtès <ludo@gnu.org>2023-10-14 22:41:43 +0200
commitf81cfc2f5104dd708853937f54d2534327e4fd8f (patch)
tree09970e71b48aea0ff5ce3f3761c93fecad04e606 /gnu/packages/display-managers.scm
parent7ce925fbe28b5baf00705908c56485e42d8b5bd4 (diff)
gnu: Add abstractdark-sddm-theme.
* gnu/packages/display-managers.scm (abstractdark-sddm-theme): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/display-managers.scm')
-rw-r--r--gnu/packages/display-managers.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index 327a29aa9e..4c46abf7af 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -35,6 +35,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system qt)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
@@ -142,6 +143,31 @@ create smooth, animated user interfaces.")
;; QML files are MIT licensed and images are CC BY 3.0.
(license (list license:gpl2+ license:expat license:cc-by3.0))))
+(define-public abstractdark-sddm-theme
+ (let ((commit "e817d4b27981080cd3b398fe928619ffa16c52e7")
+ (revision "0"))
+ (package
+ (name "abstractdark-sddm-theme")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/3ximus/abstractdark-sddm-theme")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1si141hnp4lr43q36mbl3anlx0a81r8nqlahz3n3l7zmrxb56s2y"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("." "/share/sddm/themes/abstractdark"))))
+ (home-page "https://github.com/3ximus/abstractdark-sddm-theme")
+ (synopsis "Abstract Dark theme for SDDM")
+ (description
+ "This package provides a minimalistic dark theme for SDDM, black
+background with abstract shapes. Inspired by solarized-sddm-theme.")
+ (license license:gpl3+))))
+
(define-public guix-simplyblack-sddm-theme
(package
(name "guix-simplyblack-sddm-theme")