summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-05-06 18:56:21 +0100
committerChristopher Baines <mail@cbaines.net>2023-05-06 18:56:21 +0100
commitf77d5ebb6a7d10ab8b6ef5d8b4094581c368997f (patch)
tree2ebf1afab30780a4e1012991c216c938568c52d2 /gnu/packages/django.scm
parentc3d7c09b9f8522f37a88e3a2d92ab38ce4a9c65a (diff)
gnu: python-django-pipeline: Update to 2.1.0.
Remove python-slimit as a dependency as it's no longer supported. Also make the inputs native-inputs since they're all test dependencies and users of this library should pick which things they want to use it with. * gnu/packages/django.scm (python-django-pipeline): Update to 2.1.0. [propagated-inputs]: Move some to... [native-inputs]: ... here, removing python-slimit and adding python-setuptools-scm.
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c930957805..b089954b6b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -800,14 +800,14 @@ entries, photos, book chapters, or anything else.")
(define-public python-django-pipeline
(package
(name "python-django-pipeline")
- (version "2.0.5")
+ (version "2.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "django-pipeline" version))
(sha256
(base32
- "19vrbd5s12qw4qlg5n8ldv7zz2rs5y2sdid1i7lvgp92m71dayvc"))))
+ "194j8xihx5yr1yfrssdy6nxmx8yc999pz2ai9lg83l7izmbcx9in"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -823,8 +823,10 @@ entries, photos, book chapters, or anything else.")
(setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
(invoke "django-admin" "test" "tests"
"--pythonpath=.")))))))
- (propagated-inputs
- (list python-css-html-js-minify python-django python-slimit
+ (native-inputs
+ (list python-django
+ python-setuptools-scm
+ python-css-html-js-minify
python-jsmin))
(home-page
"https://github.com/jazzband/django-pipeline")