summaryrefslogtreecommitdiff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-01 09:45:19 -0500
committer宋文武 <iyzsong@member.fsf.org>2020-12-06 18:27:52 +0800
commit4fcff5909135e9e7d56601f07ac612fa67b66d52 (patch)
tree5015d09c7710e4513226c0cd2f426af14ab06f9f /gnu/packages/dns.scm
parent8e73bf754f95fac5a383b90405e741d1cf1aaeb9 (diff)
gnu: knot-resolver: Update to 5.2.0.
* gnu/packages/dns.scm (knot-resolver): Update to 5.2.0. [source]: Add patch from upstream commit to fix the internal map() function on 32-bit platforms. [native-inputs]: Add texinfo to enable generating the manual in Info format. [inputs]: Add nghttp2:lib to enable the new DNS-over-HTTPS implementation. * gnu/packages/patches/knot-resolver-fix-map-command-on-32-bit.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 3aa3cf3e8d..85196e79c2 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -937,14 +937,17 @@ synthesis, and on-the-fly re-configuration.")
(define-public knot-resolver
(package
(name "knot-resolver")
- (version "5.1.3")
+ (version "5.2.0")
(source (origin
(method url-fetch)
(uri (string-append "https://secure.nic.cz/files/knot-resolver/"
"knot-resolver-" version ".tar.xz"))
(sha256
(base32
- "12s5070nqqf599s1mb6rjas2as481rjf751qk5yrz6p34y885k90"))))
+ "0cwlipib3x88dr6cijqv2aps13b4ijv524wc85ns07rkldy2c948"))
+ (patches
+ (search-patches
+ "knot-resolver-fix-map-command-on-32-bit.patch"))))
(build-system meson-build-system)
(arguments
'(#:configure-flags '("-Ddoc=enabled")
@@ -982,7 +985,8 @@ synthesis, and on-the-fly re-configuration.")
("pkg-config" ,pkg-config)
("python-breathe" ,python-breathe)
("python-sphinx" ,python-sphinx)
- ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
+ ("texinfo" ,texinfo)))
(inputs
`(("fstrm" ,fstrm)
("gnutls" ,gnutls)
@@ -991,7 +995,8 @@ synthesis, and on-the-fly re-configuration.")
("lmdb" ,lmdb)
("luajit" ,luajit)
;; TODO: Add optional lua modules: basexx and psl.
- ("lua-bitop" ,lua5.1-bitop)))
+ ("lua-bitop" ,lua5.1-bitop)
+ ("nghttp2" ,nghttp2 "lib")))
(home-page "https://www.knot-resolver.cz/")
(synopsis "Caching validating DNS resolver")
(description