summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-03 09:14:43 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-03 09:57:35 +0000
commite740cc614096e768813280c718f9e96343ba41b3 (patch)
tree25ade70a5d408be80f62f19c6511172aab7dcce5 /gnu/packages/education.scm
parent1b9186828867e77af1f2ee6741063424f8256398 (diff)
parent63cf277bfacf282d2b19f00553745b2a9370eca0 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 3ffc789bb9..557c86976b 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,8 +2,8 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
@@ -230,8 +230,11 @@ Currently available boards include:
(sha256
(base32
"0d387b404j88gsv6kv0rb7wxr23v5g5vl6s5l7602x8pxf7slbbx"))
+ ;; Apply patches in the order determined by Debian
(patches (search-patches "tipp10-fix-compiling.patch"
- "tipp10-remove-license-code.patch"))))
+ "tipp10-remove-license-code.patch"
+ "tipp10-disable-downloader.patch"
+ "tipp10-qt5.patch"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; packages has no tests
@@ -256,8 +259,8 @@ Currently available boards include:
;; Recreate Makefile
(invoke "qmake")))))))
(inputs
- `(("qt4" ,qt-4)
- ("sqlite" ,sqlite)))
+ `(("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)))
(home-page "https://www.tipp10.com/")
(synopsis "Touch typing tutor")
(description "Tipp10 is a touch typing tutor. The ingenious thing about
@@ -677,15 +680,14 @@ language and very flexible regarding to new or unknown keyboard layouts.")
(define-public ktouch
(package
(name "ktouch")
- (version "20.12.0")
+ (version "20.12.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/release-service/"
version "/src/ktouch-" version ".tar.xz"))
(sha256
- (base32
- "1s8pcwakx94aygfyjmyps5b43j4kv6dmfw7n12japcka2yfp9bi2"))))
+ (base32 "10lm2p8w26c9n6lhvw3301myfss0dq7hl7rawzb3hsy1lqvmvdib"))))
(build-system qt-build-system)
(arguments
`(#:phases