summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:46:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-07-11 11:46:20 +0200
commit7b151edb0de2828a3254a432c132f1683ed06708 (patch)
treec8d8ab3b69f55a0948f7b0a5e384f05b5c2344c6 /gnu/packages/emacs-xyz.scm
parent1cea926ff4859bf21e8d810e72f29099663eee19 (diff)
gnu: emacs-eldev: Update package style.
* gnu/packages/emacs-xyz.scm (emacs-eldev)[arguments]: Use G-expressions.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6520f66681..c218df65f8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18645,34 +18645,34 @@ according to a parsing expression grammar.")
(base32 "1dgbwaar8l8nl79mlzf5g1n49f1j9yj4772yfmim9vv8ppxnzbqk"))))
(build-system emacs-build-system)
(arguments
- `(#:tests? #t
- #:test-command '("./bin/eldev" "-p" "-dtTC" "test")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'prepare-for-tests
- (lambda _
- (setenv "ELDEV_LOCAL" (getcwd))
- (make-file-writable "test/project-i/project-i-autoloads.el")))
- (add-after 'unpack 'skip-failing-tests
- ;; FIXME: 2 tests are failing. Skip them for now.
- (lambda _
- (delete-file "test/upgrade-self.el")))
- (add-after 'install 'install-eldev-executable
- ;; This constructs the eldev executable from templates and
- ;; installs it in the specified directory.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (site-lisp (elpa-directory out)))
- (mkdir-p bin)
- (setenv "HOME" (getcwd))
- (invoke "./install.sh" bin)
- (substitute* (string-append bin "/eldev")
- ;; Point ELDEV_LOCAL to the installation directory so that
- ;; eldev doesn't try to bootstrap itself from MELPA when
- ;; invoked.
- (("export ELDEV_EMACS.*" all)
- (string-append "export ELDEV_LOCAL=" site-lisp "\n" all)))))))))
+ (list
+ #:tests? #t
+ #:test-command #~(list "./bin/eldev" "-p" "-dtTC" "test")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'prepare-for-tests
+ (lambda _
+ (setenv "ELDEV_LOCAL" (getcwd))
+ (make-file-writable "test/project-i/project-i-autoloads.el")))
+ (add-after 'unpack 'skip-failing-tests
+ ;; FIXME: 2 tests are failing. Skip them for now.
+ (lambda _
+ (delete-file "test/upgrade-self.el")))
+ (add-after 'install 'install-eldev-executable
+ ;; This constructs the eldev executable from templates and
+ ;; installs it in the specified directory.
+ (lambda _
+ (let ((bin (string-append #$output "/bin"))
+ (site-lisp (elpa-directory #$output)))
+ (mkdir-p bin)
+ (setenv "HOME" (getcwd))
+ (invoke "./install.sh" bin)
+ (substitute* (string-append bin "/eldev")
+ ;; Point ELDEV_LOCAL to the installation directory so that
+ ;; eldev doesn't try to bootstrap itself from MELPA when
+ ;; invoked.
+ (("export ELDEV_EMACS.*" all)
+ (string-append "export ELDEV_LOCAL=" site-lisp "\n" all)))))))))
(native-inputs
(list texinfo)) ;for tests
(home-page "https://github.com/doublep/eldev/")