summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-08 08:17:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-08 08:17:33 +0100
commit9cef3255e334ea6258b9c4b800f3f473e6cc680a (patch)
tree74611fe0dc2f71c69a2853651c993446a5c2258e /gnu/packages/emacs-xyz.scm
parent5424ca6d6e01672bf7304a4144b05a98852adbab (diff)
gnu: emacs-sudo-edit: Update to 0.1.1.
* gnu/packages/emacs-xyz.scm (emacs-sudo-edit): Update to 0.1.1.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm66
1 files changed, 31 insertions, 35 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 30f2265231..5e296e34c7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5028,42 +5028,38 @@ Gnus, e.g., for applying patches received by email.")
(license license:gpl2+))))
(define-public emacs-sudo-edit
- ;; No proper release nor tag.
- (let ((commit "0e2c32b5e5242d30f8780cbe8e1b1649476cac4d")
- (revision "0"))
- (package
- (name "emacs-sudo-edit")
- (version (git-version "0.1.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nflath/sudo-edit")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z26i4hzi2mksl4nr8szzlnrnyv96fg7jjddbm5dp5dlmh2pndk1"))))
- (build-system emacs-build-system)
- (native-inputs
- `(("emacs-undercover" ,emacs-undercover)))
- (arguments
- `(#:emacs ,emacs
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'fix-makefile
- (lambda _
- (substitute* "Makefile"
- (("\\$\\(CASK\\) exec ") ""))
- #t)))
- #:tests? #t
- #:test-command '("make" "test")))
- (home-page "https://github.com/nflath/sudo-edit/")
- (synopsis "Open files as another user")
- (description
- "This package allows editing files as another user, including the root
+ (package
+ (name "emacs-sudo-edit")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nflath/sudo-edit")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hncxbg5lvywzkwvdmzvrz71midy4samjq2vvxxhz90z1y5l8l29"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs-undercover" ,emacs-undercover)))
+ (arguments
+ `(#:emacs ,emacs
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'fix-makefile
+ (lambda _
+ (substitute* "Makefile"
+ (("\\$\\(CASK\\) exec ") ""))
+ #t)))
+ #:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/nflath/sudo-edit/")
+ (synopsis "Open files as another user")
+ (description
+ "This package allows editing files as another user, including the root
user.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-miniedit
(package