summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-09-17 19:44:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-09-22 10:54:26 +0200
commitb655f34eb4b0c43ee18eaf3b346c18fa6d9620f6 (patch)
tree09d30ab07bac029636ceb85b9acfa0746135d0a4 /gnu/packages/emacs-xyz.scm
parent9ad3c86fe563da3967a9630e6ea5732df6a58727 (diff)
gnu: emacs-lice-el: Update to 0.2-2.482e58a.
[[PGP Signed Part:No public key for 7C7AFFBEFEF2CB25 created at 2020-09-17T19:44:34+0200 using RSA]] Here is a rebased (to current master) patch. > From bc2163d6da160b58591f77f352cf4ea8543454e2 Mon Sep 17 00:00:00 2001 From: Michael Rohleder <mike@rohleder.de> Date: Sun, 6 Sep 2020 11:30:57 +0200 Subject: [PATCH] gnu: emacs-lice-el: Update to 0.2-2.482e58a. * gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.2-2.482e58a. [arguments]: Add phase 'patch-template-directory and 'install-templates. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4634836b89..72fc185e10 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16014,10 +16014,10 @@ Magit.")
(license license:gpl3+)))
(define-public emacs-lice-el
- (let ((commit "4339929927c62bd636f89bb39ea999d18d269250"))
+ (let ((commit "482e58ab83fff86ed754b00be27b62a219597e7c"))
(package
(name "emacs-lice-el")
- (version (git-version "0.2" "1" commit))
+ (version (git-version "0.2" "2" commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -16026,8 +16026,26 @@ Magit.")
(file-name (git-file-name name version))
(sha256
(base32
- "0879z761b7gajkhq176ps745xpdrivch349crransv8fnsc759yb"))))
+ "0yxkjyhfk8kpr8yqz54gdx6xwkj4s8bnbz60162jh12crj0bs5n7"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-template-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chmod "lice.el" #o666)
+ (emacs-substitute-variables "lice.el"
+ ("lice:system-template-directory"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template")))
+ #t))
+ (add-after 'install 'install-templates
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively
+ "template"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs-lice-el/template"))
+ #t)))))
(home-page "https://github.com/buzztaiki/lice-el")
(synopsis "License and header template for Emacs")
(description "@code{lice.el} provides following features: