summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2023-08-22 13:03:38 +0400
committerAndrew Tropin <andrew@trop.in>2023-08-22 13:03:38 +0400
commitdc2c851c356fb24215acbc5d14372ce93881a9df (patch)
tree13930aea00fbcdf90553bb1a028c628b82358318 /gnu/packages/emacs-xyz.scm
parent30355c17d7b7eaeb16976c1432d660cb0783014a (diff)
gnu: Add emacs-ox-html-stable-ids.
* gnu/packages/emacs-xyz.scm (emacs-ox-html-stable-ids): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f0751e39a..977d553ea5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32445,6 +32445,29 @@ simple but powerful Org contents.")
on the HTML back-end.")
(license license:gpl3+))))
+(define-public emacs-ox-html-stable-ids
+ (package
+ (name "emacs-ox-html-stable-ids")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/jkreeftmeijer/ox-html-stable-ids.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1slfc1hx6mgx6rb0h0hz7200dmpqr04sz8009r6cy7msp2b91hg7"))))
+ (build-system emacs-build-system)
+ (license license:gpl3)
+ (home-page "https://jeffkreeftmeijer.com/ox-html-stable-ids")
+ (synopsis "Stable IDs for ox-html.el")
+ (description
+ "Ox-html-stable-ids is an Org export extension package that generates
+ HTML with stable ID attributes instead of the random IDs Org's exporter uses
+by default.")))
+
(define-public emacs-wc-mode
(package
(name "emacs-wc-mode")